Forum Academy Marketplace Showcase Pricing Features

Temporarily missing data

Important update:

We just switched to a new database system (postgres instead for elasticsearch) to get better database speed.

It’s looking like some small fraction of the data didn’t get copied over. We still have the old data and are in the process of copying it now, so if something is missing, it should be back within the next couple hours. Really sorry about this.

As a side-effect of the recovery process, anything deleted while this is going on (starting from approximately ~2 hours ago) will get restored, so if you see something that should be deleted pop back up, just delete it agin.

3 Likes

Is the page structure/design also stored in the database? Seems like my app is showing as a couple of versions old.

Hmm, no, that’s an entirely different system that we haven’t touched recently. You can try using the restore app functionality to jump back to where you thought you left off… if that doesn’t work, send us a note.

Okay, the restore process is now complete. All data should have been moved over to the new database. If you are still seeing issues with data not showing up:

-Check if it’s in the App Data panel in the editor. If it’s in the app data panel, but not showing up in your app, send us an email at [email protected] with information that will let us find the item (what type it is, something to identify it by such as its unique id), a link to the page where you would expect to see it, and the search you would expect it to appear in but don’t see it in.

-If it is not in the App Data panel, email us with: anything you can tell us to help us identify the data (what type it is, things that would help us recognize it), and when the last time you think the data changed was (did you create it today? is it months old?).

3 Likes

The repeating groups load fast !!

1 Like

Still not working for me and I’ll be sending all the info asked by email. But I have a clue why it is not working. Since I read about the limit of 1000 items on the list I started to use it as foreign key, with the item on the other table referencing the owner. My data that is still a list inside the owner, not Foreign key, is working.

I just sent the email with a lot of details. It doesn’t seem necessarily related to what I said above as it works on some cases referencing the other table.

Hi Josh. I m having a issue here, www.noah-watch.com/configurator
credentials:
user: [email protected]
pass: claudiu88
The last step where user is supposed to select a box for his watch, it’s showing something that should not show. Also, if user clicks this option the price changes, and i should not.
This should be a repeating group, which searches for boxes but apparently it’s ignoring 1 constraint, which is the #id
Now i have deleted the database from development version and i need to upload all the data again from 0.
Is there a way to fix this without deleting everything?

UPDATE, even after i have deleted all the database, the search is still not working properly.
This is what i have in the database


and this is what i m searching for:

and this is what i get, even if there should be no result

The thing is that we have uploaded the website and prices are not correct. Can you help?

Can you file a bug report, and we’ll take it from there. No need to put credentials in public :slight_smile:

done :slight_smile:

Hey @josh and @emmanuel,

I’m not currently able to create new database entries for any of my apps. I assume this is a symptom of moving over to the new system? If so, any estimate on when this would be fixed?

I’ll file a bug report as well, but just wanted to check in here too.

Yep, saw the bug report. Should have a fix probably sometime tomorrow.

1 Like

Although … if you ask a repeating group to show you unique values from 6000 rows… you might be around some time :slight_smile:

Bug raised.

What if you display only 20 values / page. Lets say you have 1 000 000 records. What would be the speed?