Forum Academy Marketplace Showcase Pricing Features

The Input`s value does not change the key word in API request. How to set up it?

Hello Dear,

When I try to change the keyword in the Input, the request is starting but the key word remains the same. The results in repeating group(text boxes) remain the same.




image
https://www.social-searcher.com/api-v2/

However, when I used the approach as it was described in No-Code NLP - Analyze News Articles with Bubble.io & APIs (AYLIEN, USearch, RapidAPI)- API Deep Dive - YouTube

The search keyword function via Input element worked perfectly.
I suppose that there is something with the API request… But I do not know what to do to get the function Input to be working as it is desired.

What could be done in this case?

With respect!

You need to set up your API url for every parameter you want to be dynamic or change based on an input place it inside of the square brackets []. So your url should look like ‘…search?q=[]&limiit=[]…’. Doing that will make a ‘URL Parameters’ appear below and you just put ‘merkel’ in there to initialize the call. Then whenever you call that api on a workflow you can set q=whatever or limit=inputs value

Thus, I should change the link/request/API call from http://api.social-searcher.com/v2/search?q=merkel&limit=50&lang=en&positive,negative,neutral&key=… the API USer key… to http://api.social-searcher.com/v2/search?q=[]&limit=50&lang=en&positive,negative,neutral&key=… the API USer key…


Is it right?

Thank you!

However, when I change the keyword in the GET link


It asks me to Reinitialize Call

  1. Also, I have tried:

It looks like you are passing ‘merkel’ as the limit in your screenshot. Also see how you are using headers instead of url parameters. Look how I did this url for the api key. Maybe in the brackets cannot be empty for the URL Parameters fields to show up.

So I usually just put the name of the key inside the brackets as the value. That way it will show the key name below and the value can be dynamic

or

I have changed it but… it shows some text in the repeating groups however not linked with the searched keyword…

Ok. Also looks like you should remove the ‘Header’ where you have key = limit and value = merkel

I have deleted it but… when I try to enter another than merkel keyword into Input there is still no positive change.
May be there should be another type of API request?
https://www.social-searcher.com/api-v2/

Can you allow access to view your editor and share the link?

1 Like