Thousand seperator using "." instead of ","

Hi forum

We’re struggling making the thousand seperator work with “.” instead of “,”

We did this:

which doesn’t work. If its , it works perfectly but when we do it the other way around, it will just short 5000 down to 5…

any suggestions? Thanks in advance


So yes for the input, when checking the ‘Show thousands separator’ this transpires in the input when you start typing out the numbers in real time and adds the comma separator in there. I don’t believe there is actually a way to change the comma to a full stop/period.

It looks like from your expression above, you have composed a output that evaluates as plain text, because you have pulled in the ‘…TotalCost’ but then formated as a specific output, which comes out as text in the number formatting. You will need to ensure that for the intial content there it has to be valid and match up to the ‘content format’ so a decimal number, you’ll need to remove the ‘:formatted as’. For a text element you can reference the input (or same current cells OfferCalculator…) and output as text just as you’d like it.

So unfortunately you can’t change the input method of handling a separator in the input.

The only trick would be to potentially uncheck the ‘Show thousands separator’, allowing for the user input and then essentially use a text element to format as the exact number and in parallel use a conditional show and hide when the input is focussed.

I’m guessing that the input is necessary here for the user to freely adjust. If its just for display purposes then just stick to using the text to display the numeric output - otherwise potentially there might be a specific plugin that has an input where you have more free control over the input handling. Hope this makes sense.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.