Thousands separator - Comma instead of point

Hello team!

Does anyone know how to change the default thousands separator to comma (,) instead of a point?
Specially for a currency format input field.

The current format displays for example: $1.250,25 but I need it to be: $1,250.25

Is this possible?


1 Like

Hey there :wave:

Hope this can shed some light on the matter for you. You can use formatted as: to make it look how you want it to.

Here is an example:



1 Like

Hi @J805!!

Thanks for your reply!
Yes you’re right, I managed to do it that way for displaying, however I wanted to know if there is a way to change the format directly in the input element.
When you enter a number in a currency formatted input element, it automatically displays the thousands separator (a point) while you are typing a 4 digit number. So I want to know if that can be changed to a comma instead.
Thanks for the help!

1 Like

Does this work better:

Editor: 805testapp42 | Bubble Editor


Maybe you can share your example so I can see what you mean?

Hope that helps! :blush:


For All Your No-Code Education Needs:

  • One-on-One Tutoring
  • eLearning Hub
  • Video Tutorials
  • No-Code Classes

This is interesting because yesterday @mirko.heimburger had the exact opposite problem. He was trying to get the input to display 1.000,00
I couldn’t find a way to change this from the default 1,000.00 so I am curious how you were able to do this.


If the defaults don’t seem to be working, there is a plugin that they can use to change the formatting:

I wonder if it depends on what language they are using or something like that.

1 Like

That’s what I was wondering too.


I tried the plugin and it works for what I needed, thank you!

The only thing is that when I set a prefix like ‘$’, the value is not recognized as a number but I thing this can be fixed with the convert to number function

Thanks again for the support!

1 Like

Glad that worked! :blush:

This sort of thing shouldn’t be that difficult. Maybe file a bug report if you think it should work without the plugin. Glad you got something working though. :clap:

This topic was automatically closed after 70 days. New replies are no longer allowed.