Twilio - can't post the '+' sign in Twilio API Plugin

Hi there Bubblers,

I’d really like to use the Twilio plugin in my app to allow for phone based verification. It was all going well until I tried to send the message - I got a 21211 (400) error, saying that the ‘To’ number I’ve entered is not valid. I’ve chatted to Twilio Support and they have said: “From the error message it seems that the + is missing as otherwise it would state that the number +27837495025 is invalid not 27837495025.” I’ve also tested the API on their side and received all of the messages.

What it looks like is happening is that the ‘+’ in front of the number is not being passed from Bubble to Twilio. This can be seen in the attached.

Please help me with this.


I haven’t used it much, but last week did a quick test with the plugin Twilio - Send Text Messages (there is more than one plugin for Twilio,) and at least in that use case, the plus symbol is not needed. I only tested a North American number.

1 Like

Hi there,

Hmm, maybe that’s just for US numbers? Definitely a problem for mine and the Twilio guys seem to think that’s the issue too. Don’t know why Bubble wouldn’t pass the ‘+’ though?

@emmanuel do you maybe know?

I lieu of the E.164 format (i.e. “+1”), I think you can pass an ISO country code (in a separate parameter) if your phone number is in the nation’s correct format. I recall this from Twilio’s API docs but don’t have it in front of me at the moment.

Maybe try that through Postman?

@mebeingken Twilio uses Google’s automatic phone number formatter for US numbers, so US number can be passed to Twilio in almost any format

Here is the Twilio API page I was remembering: Lookup v2 API | Twilio


This table from that page is referring to Twilio’s response but I think the same parameternames can be used in requests:


Sorry, didn’t realize you were using a plugin.

Maybe try enclosing the non-US number in quotes for that field? “+2783…”

Hey @mccjon,

We’d be happy to take a look, give us a shout at :slight_smile:

Hi Meyer,

Thank you so much for your help! I’ve now managed to use the API Connector and got the call to initialize, though the way that worked looks a bit different to Nigel’s suggested way (I had to use Basic HTTP Auth) and add parameters. And I received my test message!! :smiley: :smiley:

So that is incredibly awesome!

Then I remembered to use the call as an Action rather than ‘Data’

Screenshot below - hope this helps anyone else!

Thanks again for all of your help Meyer and CoBubble - love this community!

1 Like

Glad you got it!

The API Connector + Twilio opens tons of possibilities (once you get over the “syntax hump” that is!)

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.