Forum Academy Marketplace Showcase Pricing Features

Twitter Card/Thumbnail still showing Bubble information after 24 hours

Hi.

When I share Bubble app link in Twitter , there is Bubble information displayed eventhough I have changed in Settings.

But in Whatsapp, it displayed my website info

How do I fix this?

Thank you in advance.

Each page has it’s own SEO section in the menu. If you double click on your page you will see SEO fields in the popup. There’s a field Image. But it can only be a dynamic image. So upload it somewhere in your database.

Screen Shot 2021-08-08 at 2.51.34 PM

1 Like

@gio.kakhiani thank you for your advice, I will try and revert back.

Hi @gio.kakhiani , it works on FB. Thank you.

But on Twitter, it still display the same Bubble information. Any idea?

Btw @gio.kakhiani , I think I will wait 24 hours based on this post suggestion

Only by putting https before my domain link the Twitter card will display correct website information

But if I put http and without http, Twitter Card will show Bubble’s information


Is there any way to fix this?

Twitter Card has changed to My website information after awhile.

If you’re on a paid plan on Bubble it should provide HTTPS automatically. This problem will sort out once you are. But if you’re paid plan user and still get this issue, maybe it’s about the metadata that needs some time to get acknowledged? I’m not sure.

I am on the paid plan. Yeah, I think after a while it got fixed. Upon checking at https://cards-dev.twitter.com/validator, everything seems fine even though at the time still showing Bubble information, so I just leave it and check again the next day. And suddenly Twitter card showing my web information.

Thank you for assisting me. Cheers.

Glad I could help!

1 Like