Unable to make live due to google geocode api keys

I am getting this error and unable to push the app to live:

Screenshot 2020-05-24 at 12.00.00 AM

I had once upon a time added “GPS Tracker” plugin. But I have long uninstalled it and the elements that it had let me create. I have no other element or piece that could be needing google geocode apis.

For so many days it has been letting me push the code to live even in spite of this error.

But since about an hour it is not letting me do so. Not sure why.

How to fix this?

Settings>> General (sheet)>> General Services API Key

Google Geocode API Key ( Api key )

Google Map API Key ( Api key )

1 Like

You need to follow instructions here to get your API keys: https://manual.bubble.io/working-with-data/setting-up-google-api-keys

Don’t forget to activate billing in Google as well. You won’t be charged as those APIs are free to use

1 Like

I think I didn’t make myself very clear. I don’t want to use the APIs itself as I don’t have a strong use-case for using them right now.

If I don’t want to use them why should I be needing to create the APIs?

Also, the APIs don’t seem to be free to me, and that’s one reason I wanted to avoid using them for now. Here’s what Google tells me. Am I looking at wrong place?

I think that you can enter any thing you want in it to make the message disappear but only if you really don’t use it anywhere.


Ah thanks. I feel stupid now to not have tried that.

It worked!

But it is weird of Bubble to be putting this restriction. Maybe there is a geocode element somewhere in my app and I am not able to find it. I did the search given by Bubble to find elements/actions etc.

Bubble have native Google Geocode function. You don’t need to have a specific element or an action that use it. Bubble automatically request this since a few weeks now.

Ah interesting. Thanks.

Then they should fix the UX such that people like me don’t get foxed.

This still hasn’t been fixed. It says they are necessary once using your own domain, but then it won’t let me deploy live without them, even though I’m not using my own domain yet.

Did you read the solution? Your screenshot doesnt show you applied it.

Yes, I typed in a sentence to get around it as recommended above. However, I shouldn’t have had to spend 20 min troubleshooting and then come to the forums and figure out it was this when Bubble states right there that it isn’t required.

The failure to go live message is a general message saying 1 or more “errors.” It took a while to figure out this was causing this issue because I have a few “errors” that are intentional where Bubble doesn’t like that I am navigating from one page type to another and won’t let me send data (works just fine because it calls from user).

Thanks this saved me, @Bubble please fix the UX so one doesn’t have to troubleshoot

Bumpup here!

Have spend also 20is minutes to find the solution.

Not good UX [Feedback]