Google Geocode API not working

I want to use the plugin “Geocoding from Google” to request the user to type in a geographic location in a searchbox and save it to the database. I added the pluggin in my bubble app and then I went to to create a “new project” and clicked on “enable” on the “Geocoding API”. Then I went to “credentials” to obtain the “API Key”. I copied the API Key to bubble settings - general - “Google Geocode API Key” and “Google Map API Key” and when I run my app on preview the geocoding feature does not work. The following shows up:
“Geocoding Service: This API project is not authorized to use this API. For more information on authentication and Google Maps JavaScript API services check
Does anyone know what I might be doing wrong?

I was able to configure my APIs in Google, but couldn’t get them to work until I set up a billing account. As soon as I set up the billing account, my app worked as intended and the “development purposes only” watermark was removed from my map.

That said, a quick followup question for @anon91833042—when would my billing account be used? Am I going to be charged to test my app? What changes will I need to make when pushing an app live?

1 Like

You will get $200 free credit per month from google this should be more than sufficient for testing

1 Like

Hey thanks for the info @anon91833042 & @dylanwares! And hope you were able to get your issue solved @mateo.mulder

That is what fixed for me, thank you. You need to setup billing before it works.

Should be in the Bubble Manual :wink:

Hi @mateo.mulder ! I think I am trying to do something similar to what you’re doing but I can’t figure out how to get this plugin to work.

I need to extract latitude and longitude from the input address.

Would you mind sharing a screenshot of how you set it up for your use case?

Thanks in advance!

I had the same issue and got resolved by setting up the billing account and linking it to the Project that was created for enabling google services.