Unable to setup a login workflow in run mode (with debug_mode=true in the URL)

Hey Bubble Team,

I am trying to authenticate using a 3rd party OAuth service. All the calls are being executed fine and even the user is getting created in the bubble. But the user doesn’t stay logged in. To test this, I am displaying the logged in user’s email on the screen, which gets visible for a sec and then disappears. not sure the reason behind it, Haven’t applied any conditional or workflow to hide or sign out afterward.

Because of this, I am unable to config my API calls further and the below warning doesn’t get resolved even after trying to perform the suggested method.

Even after a successful call, I am unable to stay logged in. Can anyone suggest me something here? @emmanuel @NigelG

You don’t need to create an account for someone else. You need to use signup login and this will automatically create a user in your DB.
When you are in debug mode/version-test, this should return you a message that you are ready to configure the call now. I suggest to clean DB to avoid conflict. In some case, you may need to reauthenticate your “backend” user.

Also, I suggest to test accees_type-offline OR check if the API you are trying to reach have a similair option. In some case, this is in scope.

Finally, be sure that the profile endpoint have the correct path/key for ID and Email fields.

Thanks, @Jici for the reply.

I tried without the “Create an account for someone else” action but it wasn’t creating any user in the DB hence added the same and it was working fine earlier.

I also tried the cleaned DB method to avoid conflict but didn’t work out. Also, even after authentication, I didn’t receive any alert mentioning that API is configured and I can use it further.

Also, tried with access_type = offline checked. Still same issue.

Check the profile endpoint as well, it has the exact same keys for id and email.

In some case, clear cache and retry. After a first initialization, it happen often that I need to do that or retry a couple of time to get the message. Also, be sure to not be logged in with an account. This can help too.

@Jici
Thanks again for taking out time. I tried in incognito mode as well, but still the same behaviour from the app. It gets logged in for a fraction of seconds in which it displays the email and id of the user and then log out immediately.

@emmanuel @NigelG Could this be a bug? This is a major blocker for me for this project. I tried to replicate the OAuth in another application as well, but its behaving the same way.

1 Like

Did you ever figure this out?
I’m trying to figure out the same thing.

2 Likes