Unix (date) via API not showing correctly

I have unix dates in milliseconds being returned from an API.

I have set in the API connector on the date fields that they are date (unix) as per this screenshot

I have a repeating group that references the result from the API and have added a text field in the repeating group to show the date, as follows :

image

When the repeating group displays the data, the date is printed like this :

image

The unix date ( 1658144888934 ) is valid

image

Does anyone have any ideas as to why this is occurring?

I’ve read that conversions of unix dates that are in seconds needs to occur, but bubble natively understands unix dates in milliseconds, so unsure as to why the date is not being displayed correctly.

I’ve tried applying formatting to the result, but the date never displays correctly.

Thanks for any help.

Hi!

Easiest would be to find a community plugin to do the proper conversion.

What i do is UNIX / 1000 added to JAN 01 1970.

Maybe there’s a better way but it works for me.

Thanks @ihsanzainal84 for the response.

Will certainly try your suggested approach, but it does make me wonder why bubble has a date(unix) type field for integrations when it doesn’t actually work correctly. Possibly a bug?

So at the risk of having egg on my face over how simple this issue was to fix, I wanted to post the solution to my issue.

Even though my date is coming from my API as a UNIX date, simply setting the field type to date in the API connector for the field actually fixed the issue.

Still confused however as to why date(UNIX) exists as a field type ; perhaps to handle unix date’s that come through in seconds???

This topic was automatically closed after 70 days. New replies are no longer allowed.