Url parameter not being passed to new page

Hi folks

I am struggling to send a url parameter to a new page. I believe it is set up correctly, but it is not sending the parameter through. The workflow is triggered from a repeating group item.

image

The url on the front end does not seem to to be passing from the workflow, and is ignoring all the rules set.

image

I have tried clearing cache and preloading, but no luck

The find & replace may be the problem … it may not be having time … to “find” and to “replace”.

Process the find/replace data and send it ready before using the go to page action

It was working perfectly before, but even with removing the find & replace still does not work

image

image

Been having weird issues lately with cache and repeating groups not showing full lists until reload, etc. Not sure if is related

Make sure that the go to page action is the last action of the flow

It is the only action in the workflow
Sorry, forgot to add that the url is ignoring the id parameter altogether

Check privacy rules

Disabled all rules (I am using Supabase as a backend & nothing has changed in the DB), but still nothing.
Perhaps I need to report it as a bug?

I do not think so

If this was a bug the forum would be going …

Strange, all I did was copy the workflow to another element and delete the original. Will try to redirect to the same page see if that works.

Hi there,

What happens if you assign the ‘Data to Send’ field?

Hi, nope that never worked, but, turns out Bubble does not seems to like “id” as a parameter key. If I use “i”, then it works

image

Maybe someone else can confirm

2 Likes

You should report it to bubble maybe they can elaborate if this is the issue.
I’ve never used id in a param i always state which id im sending like cat_id for categories and also try to use _ instead of - in url