URL Parameters Showing Groups

I have a button that reloads the index page and passes a unique id as a url parameter. When this url parameter is not empty, a group is supposed to be unhidden and replaces another group. The url is being sent but the group is not being shown and I cannot figure out why. I have attached screenshots of my configuration. Anybody have any ideas what could be happening?

Screen Shot 2021-03-03 at 10.59.17 AM Screen Shot 2021-03-03 at 10.57.51 AM Screen Shot 2021-03-03 at 10.57.39 AM

Is the group configured as initially hidden - i.e. “visible on page load” is unchecked?

Yes it is hidden initially.

Could it be a nesting issue? Is the initially-hidden group inside another group that’s also hidden? Or conversely, does the initially-hidden group contain another group that’s also hidden?

No, everything is unhidden within the group. If I change the the Group requestDetails to show on page load, it shows up fine. Also, if I set the conditional to
Get quickRequest from page URL is empty the group shows up. It’s something to do with the conditional not seeing the url parameter even though it is showing in the url box.

What I think is happening is that using “Go to” to navigate to the same page doesn’t actually reload the page, so Bubble is “unaware” that the URL has changed.

If you manually refresh the page when the query string parameter is in the URL and the group appears, then that’s the issue.


I did a quick test, and the above is not the case. Bubble DOES recognize URL changes when “Go to” is used.

I tried that and still the same thing. The thing is, I have this same exact thing (with different URL parameter) set up to bring up a different group and it works.

If you can point me to the page, I can have a look. PM me if you don’t want to share it publicly.


Just to mention the obvious, there’s nothing covering (in front of) the group, is there?

not seeing how to send a pm

Click avatar. Click Message button.

it says I’m not allowed to pm you.

Possibly because this is your first post. I’ll just PM you, and maybe you’ll be able to reply.

This topic was automatically closed after 70 days. New replies are no longer allowed.