Vimeo not transcoding video

I have built the following API model (following @adamhholmes instructions) and it works.

.
I.e. I manage to upload the video in Vimeo.

However, the video is not transcoded, its status remains fixed at 0% (first video):

This is my workflow:


E.g. I cannot transcode this video URL

Does anyone know any reason for this?

Is it happening every time you try to upload?

yes every time. the video that worked (in the picture) was uploaded manually from my computer files

Has the file been uploaded correctly to you Bubble storage?

yes, when I click “see” a new tab is opened and I can see the video (url is this)

image

Strange… everything is working fine for me…

I notice in your screenshot of your API set up that you haven’t entered anything in the ‘scope’ field.

I’d have thought that was fairly important, so I’d try it again making sure you enter your allowed scopes in that field. I don’t know if that will help (I’m surprised the API call works at all without any valid scopes). So give that a try.

I’m assuming you’ve initialized the call in the API connector?..

So did it work then (i.e. was the video you used for initializing the call uploaded successfully to Vimeo?) If not, did you get any kind of error message in the call?

1 Like
  1. I entered the scope (somehow had forgotten it) private edit upload public. Still not transcoding.
  2. Yes, I have initialized the API connector.
  3. Uploading to bubble works (i.e. when I click “see” in the pic above I can see the video). But, uploading to Vimeo does not, or at least it does (because I can see an entry) but it does not transcode. I did not get any error message.

So did it work then?

Yes, initializing the API works (see pic), but it is the video in Vimeo that is not transcoded

I.e. pressing this button, produces the pic above. I think this is what you mean with “initialized the API connector”, right :sweat_smile:?

That all looks good to me…

The only thing I can suggest is contacting Vimeo directly to ask why there’s an issue with transcoding the video - the issue definitely seems to be on their end as it seems to be uploading ok, and the issue is just with the transcoding.

1 Like

:+1: thanks

Tell me please how I can track studing abroad consultants of Lahore or how I can contact them.

hey @adamhholmes still struggling with this. I have been talking to the Vimeo support but they have been slow in answering and we have not had any results.

I have a question. Do you know what the Warning in the picture of this post refers to “You haven’t tested this API in run mode and authenticated with Vimeo API yet. You need to do this first to setup calls and to test the URLs and keys…”.

I searched the forum and did not see a solution…

Your tips regarding the contact of studying abroad consultants in Lahore were very helpful for me. Thanks a lot!

This topic was automatically closed after 70 days. New replies are no longer allowed.