Vimeo Plugin upload not working

Hi @lindsay_knowcode,

The vimeo upload plugin isn’t working for me and I am having a hard time debugging it.

I am using the V2
I follow the entire procedure here:
Added bearer before the token in the plugin generated from vimeo with edit and upload privilages
I tryed both file upload and file multi-upload from bubble, they are both giving me S3 links that look like these: //
I verified workflow is triggered and file name is passed to the plugin step that looks like this:

PS. I also tryed filling in description but still doesn’t work.

But I can’t see any video in vimeo, I guess the API call is failing for some reasons… can you provide any support in debugging and making the plugin work for me?


Of course :slightly_smiling_face:. The best thing to do is to capture the debug message that is returned by the plug-in, after the the action to upload in the workflow. Write the debug output into a custom state or table so you can inspect the debug message. Look at the example app to copy how it’s done in the example app. It will tell you what Vimeo responded with in detail.

The other thing to do is to hard code in values temporarily for the Url and name so you have values you know will work. Then you can see where the problem lies, with credentials or with the url.

There is a trouble-shooting section on the plugin service page explaining how to debug issues also. Just converting the page to new responsive so will be changing a bit. :slight_smile:

Thanks Lindsay , it worked and as you said it was because the s3 link was missing the https: and Vimeo was rejecting it. Maybe it is worth mentioning this in the tutorial since most people are using the default file uploaders from bubble which create S3 urls without https:

1 Like