We found bad DNS records for your domain

I have been trying to connect my domain to my Bubble.io app, but I keep receiving an error message that says ‘We found bad DNS records for your domain.’ I have followed the instructions provided by Bubble.io and added all the A records to my GoDaddy DNS, but I’m still having issues.

Can you please provide a step-by-step guide to properly configure the DNS settings for my domain in Bubble.io and GoDaddy? I want to make sure that I have done everything correctly and that there are no conflicting DNS settings.

Also, can you please let me know if there are any known issues or common mistakes that could cause this error message to appear even after the correct A records have been added to the DNS?

Thank you for your help.

What are the bad records? (Does it say what they are)?

Please refer this screenshot.i didn’t understand why this is not working. i already added this all A record in my go daddy DNS. for last 4 month its working fine. but from yesterday its display DNS error.

Have you checked in GoDaddy?

1 Like

They said there’s no problem on their end. I have another project that I added as a subdomain, and it’s working properly. However, my main domain is experiencing this DNS issue.

Hello Everyone,

I am also facing with the exact issue but bubble support team is not responding properly. Does anyone have the solution for this?

I have the same situation

I accidentally created a workflow that kept running in a loop, which caused a DNS issue. I reached out to support for help, and they advised me to check the system log to find the problematic workflow. After reviewing and confirming the issue, I deleted the workflow. Within 2 to 3 minutes, my system was back up and running smoothly.

Same issue here, 3 days and still not resolved. It looks like bubble support team doesn’t have any control on DNS related technical stuff. I entered the correct DNS records but still no avail. Thats aweful and shows how much you can bank on bubble support team in the future.

Have the same problem. Anyone solved it?

Exact same problem here.
Same message. And Support is not reponding. I have not been able to Preview my site and my live site is unaccessible - 1 full day of not App running !

Setting up a new domain name and wait 96 hours for propagation!

I waited, waited, and waited, until a tech support specialist at greengeeks.com deleted the DNSSEC record and bam! It took 6 hours and my site was up.

No one else had thought of this. So, in conclusion, bubble.io should add to their instructions something about propagation taking very long and a list of checks to do, the most important one for me was the DNSSEC record at my registrar for my domain name.

Here’s some info about DNSSEC : https://www.icann.org/resources/pages/dnssec-what-is-it-why-important-2019-03-05-en


1 Like