Forum Academy Marketplace Showcase Pricing Features

'We found bad DNS records for your domain': what to do

I’m trying to configure my DNS records to point to my purchase domain (from Google Domains). I added the 4 DNS records that bubble provided me with and understand that it can take up to 48hrs to propogate. I want to make sure I have configured them correctly.

Here was my step-by-step:

Step 1: Add my domain into Bubble under the domain/email tab
Step 2: Add Bubble’s 4 IP addresses to custom resource records in Google Domains
Step 3: Waited several hours.

Normally, I would just wait for 24 hours. However, Bubble used to say “we haven’t found DNS records” but now says “We have found bad DNS records for your domain”. Has anyone else experienced this? If so, how did you fix it?

Thank you,
Michael

I am in that exact same hurt box since Friday. I am going to try and log it with Bubble today.

Hey there @q49b863,

I’ve had no problem with google domains in the past, maybe try clicking “Check settings” in Bubble? But don’t spam the button

Are you using Google Domains as well?

I was…but I then switched to GoDaddy today with a new domain and it has been plain sailing since then. Live on the custom domain within 5 minutes!

1 Like

Hey Johnny,

Thank you for replying. I have had a great experience with Google Domains in the past, which is why Im surprised I’m experiencing this issue.

I have used the “check settings” in Bubble and it says they’ve found a bad DNS. Google Domains support said this was due to the time to propagate.

Thanks,
Michael

Can you send a screenshot of what you see in Bubble?

Hey Johnny,

Here is what Bubble is showing me.

And what’s your setup look like on Google Domains?

9.9/10 times it’s a bad configuration your end. Keep trying!

Hi

Kindly check the domain SSL is enabled or not from Google domain. But I not tried before on Google domain.

Non-ssl domain can be bind successfully with bubble after adding of A records. I have tried with 1&1 & GoDaddy

1 Like

Here is my Google Domains Setup:

Thank you for your response!

Google domains says that I have 5 of 8 SSL certificates. I am not sure how to obtain the other 3 and if that is the root of the problem.

Thanks,
Michael

Hmm, this is very strange… maybe @eve can help here?

Actually another idea is to get rid of the A records you have right now and replace them with a CNAME record of app.bubble.io and see if that works.

Your setup looks okay! Can you shoot us an email at [email protected] with your domain? There might be something we can adjust on our end. :slight_smile:

2 Likes

Hi Eve! Thank you for reaching out. I am currently talking with Jess (via [email protected]) regarding this problem. Would you like me to send another to that email address or just keep it on the current chain of emails?

Thanks,
Michael

Solution

I went to the Domain/Email tab in Bubble, deleted the domain, waited a second, then re-entered it. That solved the problem.

Originally, I didn’t want to re-enter and risk another 48 hr propagation period. However, this must have been a small glitch on Bubble’s end. @jef.van.hoeck posted this solution on a different thread for a similar problem. Thank you, @jef.van.hoeck! Thank you all for your responses, I am thankful for the quick help!