When I run my page preview with the debugger on, the page doesn't work and hangs. When I view it without it, it works perfectly. What's going on? Please help!

I’m not really a tech person. As title says… I don’t know what’s wrong. I’ve tried switching between “Run” and “Step by step” also but it doesn’t even do anything, just freezes the same. Anything that I click on starts loading infinitely, just ends hanging basically. I can’t even click one button. It’s now been some days and truly I don’t remember changing anything specific before it happened that’s out of the normal editing UI/workflows… I really need to fix some issues going on for my users but not being able to run the test version with the debugger on is hurting me a lot since inspecting elemens is really important for me to fix problems. Anyone know what could be happening?

I tried searching the forums but found nothing… In the picture you can see the loading bar at the top. This is what happens each time I try to click anything, absolutely anything. Nothing works at all, even the debugger options. Alternating between “Normal”, “Slow”, and “Step by step” doesn’t trigger anything . The only thing that ever happens is the infinite loading bar…

Clicked on variety of buttons, all generate the same response:

If you let it go for unlimited time, it just reaches the end but never actually does anything and stays “loading”. Happens with anything you click. the regular www.website.com/version-test without the debugger on works perfectly fine… also forgot to add, inspecting on the currently visible elements works well, but since nothing works it’s all I can reach to inspect… any pointers would mean a lot

Hey @julpereira82 :wave:

Hmm :thinking: Maybe you can show us a video of what is going on? That might help us troubleshoot the issue. :blush:

I don’t really have a screen recording software but that’s a good idea… added some pictures now to hopefully clarify a bit more. Thank you

Hmm :thinking:

Can you share a link of the test page so we can do an inspect with Chome?

That has happened to my app if there was an api that ran and failed without proper error handling or a Do every 1 second type workflow can cause that. Do you have some sort of API going on or a crazy Do every 1 second workflow?

1 Like

Thank you yes! It seems like it was indeed something weirdly changed to one of my plugins. Considering it felt like it happened randomly without any changes out of the ordinary on my part, totally makes sense the changes were from a different side.

Thank you very much, means a lot to have it fixed and I’m really happy it was a quick solution. I tried for days but didn’t come to my mind it could’ve been a plugin… go figure…

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.