Workflow not changing state (only when condition)

Hey crew, I need some quick help. My workflow is not changing my state when using “only when”. What do you think the reason is? Here is a quick 90 second video: Click here

Thanks for any help!

Hi there, @SlamDuncan… the short answer is don’t combine the actions into a single workflow event because both actions will attempt to run (and not necessarily in sequence), and that can cause conflicts. The way you have it with two workflow events (with an Only when condition on each event) is a good way to go.


1 Like

As you’ve discovered, you can’t use a single workflow to do this (at least not the way you’re currently doing it), as the two actions will cancel each other out…

i.e. if the state value is ‘yes’ then then first action will run and change it to ‘no’… then the second action will run (as the state value is now ‘no’) and change it back to ‘yes’… so basically nothing will change.

So it’s better to keep the two workflows separate…

That said, it is possible (and perhaps simpler) to do it with a single workflow, and even a single action, by setting the state value to its current value is "no" which basically acts as a ‘toggle’ on the yes/no value…

1 Like

Hey Adam, thanks for the reply! I’m not following you here…

The state value’s default value is “no”. Would you mind explaining a little further where I would make those changes?

Thanks Adam!

1 Like

That worked :muscle: Thanks Adam! A little non-intuitive from the bubble side, so thanks for the explanation!

1 Like

I didn’t know about that little trick, Adam, so I’ve always gone the two workflow route. Great stuff, man… thanks for sharing.

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.