Workflow Trigger When Input Value is Empty

I need to trigger a workflow when an input’s value is empty. I’ve tried the following below and nothing actually triggers it when there is no value there. How has anyone solved for this before?

  • set “only when this input’s character count < 1”
  • set “only when this input’s value is not empty”

Hi there, @randyw… can you share more details and maybe some screenshots? What is the workflow you are trying to trigger? What does it do? Checking to see if the input’s value is empty in a condition on a workflow event should work, so without more details, it’s hard to know what’s going on.


@mikeloc A current workflow I have is triggered by “when and input’s value is changed”. The action I’m trying to achieve is a data update based on a “do a search for” condition. I have no problem with this when there is a value in the input field but I need to be able to trigger the inverse workflow when the input field is blank/empty.

Sorry, but I’m still not following because if you put an only when condition on a workflow event that says the event should run when the input’s value is empty, I’m thinking you should get the desired result, whatever that is. Again, screenshots would probably help.

1 Like

I would suggest that you try it @mikeloc
See the screenshots below. Since the trigger is “When an Input’s Value is Changed” I don’t believe Bubble recognizes “null” as a value so it’s not triggering. Let me know if I need to clarify anything here.

Thanks for the suggestion, but I had already tried it before I replied, and it worked as expected. Have you checked the debugger to see why it might not be working for you?

Thanks for your help here @mikeloc Yes, I’ve debugged and I can’t see anything. Can you share your setup so I can see what the difference is? Do you see anything wrong with mine? Perhaps I can record a loom and share it with you.

Sure, a loom couldn’t hurt. My example wouldn’t help because it was just a simple example to see if the only when condition would work, and as I mentioned, it works as expected. Are you sure your search is returning an item? And because they often end up being the culprit, do you have any privacy rules in place that could be getting in the way?

Look towards the end of the video where I clear the input field and nothing triggers. Let me know if you see something I am missing. Thanks!

Well, first, and most importantly, how’s the pizza?

Second, I must be missing something. I believe you are asking why a workflow event with a condition on it that checks to see if an input’s value is empty isn’t running, and you are entering a value into the input. So, the input is not, in fact, empty, and the workflow event is correctly not running. What am I missing here?

Okay, check out this second loom where I narrate through it. The pizza was great by the way; almost burned it dealing with this though. :slight_smile:

Ah, I get it now, and I know why it’s not working (which I just confirmed with my example). I’m pretty sure you have the This input should not be empty checkbox checked for that input, so the input won’t run a workflow when it’s value is changed and the input is empty because the input is not allowed to be empty.

You’re right! I do. Thanks for digging into this one with me here. I had " This input should not be empty" as a condition which was evaluating to true. When I turned it off it ran as expected. Thanks!

Now to solve the formatting for when it is blank to replicate the native required field formatting…


Haha THANKS for this! I was about to lose it because my workflows refused to be triggered