Forum Academy Marketplace Showcase Pricing Features

ZQ Rich Text Editor - New Plugin From Zeroqode

We have just published a very powerful Rich Text Editor Plugin

This Rich Text Editor can be easily converted to read only mode for your users, so you can be always sure that they see the text structured the way you planned while writing.

Easy switch to read only, display mode, limited number of characters, saving content in browser storage before publishing, hashtags and mentions are just the key features, that make writing content as easy as possible.

Simply place the plugin on the page, set up the properties and your users will start writing amazing stories.

Check out the plugin page

and a demo -

Levon Terteryan
Founder @ Zeroqode & Bubblewits


Bubble Templates
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services


Looks cool but the buttons in the demo don’t seem to be working properly?

Also how would we show and hide the editor options depending on view. The read only mode still shows the editor options and on the lite version how would I show the editor options?

Hey Brad, which buttons don’t work? We have tested all them, maybe it’s not very obvious what they should do?


That might be it. I was specifically looking for the button that hides and shows all the editor options, so one could have a read only mode without the editor options. Perhaps a tooltip on each button would better clarify what does what.,

Also is there a way to hide the editor based on a condition?



Hey Brad,
the plugin doesn’t have a workflow action to hide/show the editor options at the moment. The lite mode is enabled through the plugin properties. And you can have 2 editors (full and lite) and show/hide them depending through the conditional formatting.
Hope this helps, but please let me know
Levon Terteryan
Founder @ Zeroqode & Bubblewits


Bubble Templates
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services

@levon, am I setting the data type and column name correctly, or should this be some kind of dynamic data? The editor does not show up with these settings:

Hey Petter, it seems we forgot to include important thing in the instructions. For the mentions to work you should do the following:

  1. Go to the Settings - API, Click on “This app exposes Data API” and check the table which you want the editor to access (in your case it’s Users).
    see the screenshot

  2. Go to Data - Privacy, choose the table where the plugin will be searching the users in and define a role that would be allowed to access the data. (something like on the screenshot would suffice)

please give it a try and let us know if it works. Sorry for overlooking this part of instructions.

Hi Levon, that worked :slight_smile:

Sorry for the late reply, I have not been able to test this until right now.


When I add this element to my page, I can see the element in the editor, but when I preview the page, absolutely nothing shows up. If I add a border to the element, I can see the border on the preview page, but it is completely blank inside. No toolbar with formatting options. No where that I can type anything. I don’t understand. Can you please help me?

Hello, did you follow configuration steps as explained in the plugin instructions? That’s important, otherwise it won’t work

The instructions say “for the mentions to work” do the following configurations, so I didn’t think I would need to do that if I wasn’t going to use mentions. I don’t really know what mentions are, actually. But anyhow, I unchecked the “enable mentions” box on the editor page and now I can see the input box in the preview page. Thank you! I may have more questions, so I appreciate your quick response.

I still can’t seem to get this element to work correctly. The initial content seems to not work as I’m expecting it to in my repeating group. I have a Thing (Jobs) and each one of those Jobs has one or more Thing (Options). Each one of those Options has one or more Thing (Phases) associated with it. Then each one of those Phases has one or more Things (Action Items) associated with it. The Rich Text element is supposed to allow the user to view/edit the Thing Action Item.

I’ve set this structure up in a repeating group that is filtered to show only the selected Job/Option Thing. The repeating group then shows the Phase Thing and the Action Item Thing. When I change the selected Option, the repeating group updates itself to show the Phase/Action items associated with the newly selected Option. I believe this Repeating Group Data structure is okay because when I use Bubble’s Rich Text Element or even a regular Multiline Element, I can view and edit the expected data.

However, when I make the Action Item element a RTE-Main Version element, it no longer works correctly. When I initially select the Job and Option and view the repeating group, it appears to work correctly. However, when I select a different Option, the repeating group’s Action Item doesn’t update itself. Its like its not updating the initial content value when the option is changed.

Regular input Option 1:

Regular Input Option 2, Action Item text updated correctly

RTE Input Option 1 initially displays correctly

RTE Input Option 2, Action Item text does not update to reflect the newly selected Option

Can you help me figure out what my problem is? I really like your Rich Text editor better than the other options, specifically because it has a better outline behavior and would like to keep it in my app.

Thank you.

Hi levon,

found your RTE just today and checked it out, nice feature. I have only two open questions:

  1. When extracting HTML from the editor and putting it into a custom state of type text, the transaction seems to work only after having focussed a data receiving object by hand, which in my case is an input form or HTML box. Why is this ? Never had it before that a custom state’s update depended on some element down the data line being focussed by hand. Does data acquisition from the editor rely on some other condition than just a request by a workflow ?

  2. Is there a possibility to add fonts ? The clients would appreciate to have access to the google font spectrum. It doesn’t need to be all available at once, but it would be nice to customize the editors fonts library and add some specimens. Can this be done?

Thanks a lot for any help, all the best, O.

Solved the first one: In any workflow using the ZQ RTE content, start it with the action “Remove focus from the editor”. Without the removal no content is ever extracted.

@levon I’d love to be able to pay for your plugin. Like I said, I like its outline functionality better than the free Bubble Rich Text Input or any of the other paid plugins. Can you please help me figure out the problem I’ve described above. Please let me know if I wasn’t clear in my explanation or you want access to my app.

Hello, sorry for the delay, we’ll try to help you out shortly @accounting and @ones

Hi @ones ,
In fact you can list your fonts in the field “default fonts” Separated by comma. So if the fonts are available in bubble (or can be added there), you can allow them also in the RTE.

Hi @karel

thanks for the response, but is this about the ZQ RTE? I cannot change the preselected fonts, as they are fixed part of a dropdown menu :

Are you referring to another editor maybe?

Good evening, O.

@accounting What you are saying is correct behaviour, and even it seems wrong, it’s not an issue. What you face in your app, is that the RTE has priority on the edited content, as it’s mentioned to edit data and not to display.

What You can do is to call RTE action “Set Initial content” in the workflow, that will reset the editor, and use the new content as you define within the field “initial content”.

Please let me know if this is working solution for you, or you would like to achieve something else.


My apologise,
I checked it in the plugin editor, but didn’t notice that it behaves differently in bubble. Let me check with the developer if the behaviour can be changed into the one I mentioned and get back to you.