Accessing API without key/value pair

Hi, here is an API I would like to access

Th problem is that there is no key-value pair to use to gain access and I believe bubble assumes there will be.

The string of characters at the end (a crypto address) changes. How can I addend, inside of bubble , to the API call without a key pair?

I want to use the api call so that what goes to the website are the above.


Which I understand how to implement.

Are you doing this “append” in Bubble?

Well, right now I’m not doing anything in bubble. I want to do the append in bubble. So I would like to tell the API connector use “” but then in the program somewhere I would like to append the actual address.

Are you trying to get data back from the address or just send the user to the address?

I am trying to get data from the address

Use should be able to use [] to specify a parameter in the URL.[address]

Then you could put the following in the address parameter of the API connector to set it up. Ddsf78bg6ds876bds7bf6sd8f76bdsb678bg877

After setup, in your workflow, you would pass the “address” as part of the API call.

1 Like

Nope. When I do that bubble tried to stick the address into a key in a key/value pair.

Literally use this[address]

That will make “address” as the key. Instead, you named the key “dah…”.

You’ll put “dah…” as the value of the “address” key.

1 Like

Ah. Yeah, sorry. I tried to do that too. It still doesn’t work. I think because what it really sends is
Which is not the format the website wants


Works for me.

1 Like

My attempt.

That’s odd. Try creating it in the Plugin Editor, instead of the API Connector plugin. There’s a couple more steps involved, but it appears to work from there.

The problem is with the empty Header you are sending, try either deleting the header, or recreating the API call.

1 Like

OK, that seems to work. Now I just have to figure out how to make this usable for within my app.

I have tried those. I simply cant get it to work with the native Api connector. But with the plugin generator it seems to work.

There is a bug with the API Connector, the call definition gets corrupted if you create and delete headers, I’m unsure of the exact sequence that causes it. Did you try and create another call?

It should look like this, without Headers or URL Parameters …

ah. I didn’t. I will try that

What I mean is that yeah, in my attempts to get it to work, I created and deleted headers within and without the api call. Its cool. I will get this. And now I’ll try just starting fresh.

This was the problem. Thanks

1 Like

Is there any reason why the Bubble API Connector will not let you replace the entire path using a variable. We are building an app that users have different domains and we want to pass the domains ( vs to the API Connector from a user configuration data element. We are creating an app for WooCommerce customers so the root domain url changes but the endpoints are also variables (e.g /wp-json/wc/v3/products; or /wp-json/wc/v3/products/categories) So essentially the API Call is one big set of varaibles - a variable for the url, a variable for the endpoint and a parameter variable for authentication.