Advanced filter and Ignore empty constraints

Hi,

Just checking if anybody else is experiencing similar bug with an advanced filter and “Ignore empty constraints”. Not sure if it’s related to custom states or what?

This search works fine if list of custom state (osfCertificates) is not empty.

This initially threw me off when I was doing an advanced filter, but I got my head around it. I believe “ignore empty constraints” is intended for a regular constraint within your filter (like datatype field = input value). With an advanced filter, it would be difficult for Bubble to know what part of the advanced filter it should apply to, so I’m guessing that’s why it doesn’t apply.

You can fix your issue by putting a conditional in front of your expression, so it starts off as…

Advanced: search’s OsfCertificates:count is 0 or (and then what you currently have)

If you do this, the advanced filter will only apply when that first part has a value.

11 Likes

How big is that list of osfCertificates? I’m asking because if it’s large, setting that as a state might cause problems. Might slow down your application or crash the page (specially if mobile).

It’s a short list: 10-15 certification types.

@ed727 Thanks for your tip. It saved quite a bit of my time.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.