[Need Help] Ignore empty constraints not working on list filter

Hi, I am trying to show a list of genres, and have a filter set up so that I can also search those genres.

However, although the filter has “ignore empty constraints” ticked, when there is nothing in the search it is still not showing me the list of genres.

Have tried looking through the forum and elsewhere, can’t work out my mistake…

Thanks, A

Hi there, @StandUp… to the best of my knowledge, the Ignore empty constraints setting doesn’t work with filters, so one way you could go is to add a conditional to the repeating group and change its data source when the constraint is empty.

Hope this helps.

Best…
Mike

1 Like

As @mikeloc said - “ignore empty constraints” doesn’t work for advanced filters:

(source)

For our advanced filter you can add something like OR XXX:count is 0, where XXX is the list you are filtering with.

1 Like

What type of element is your ‘Input Search book genre’? (and what Type is the value of it?)

In any case, just add or Input Search book's value is empty to the constraint to make it behave like it’s ignoring empty constraints.

(so the whole constraint will be(Input Search book genre's value's Display is This Genre's Display) or (Input Search book's value is empty)

Although you probably don’t need to be comparting ‘text’ values here… (surely you can compare the option set values… unless they are not the same?)

2 Likes

Thanks everyone, much appreciated and some good learning for me. A

This topic was automatically closed after 70 days. New replies are no longer allowed.