Forum Academy Marketplace Showcase Pricing Features

🖥 Agora Video Conferencing (WebRTC) and Streaming with Cloud Recording - New Plugin from Zeroqode

@ZeroqodeSupport
Thank you very much.
As you said, using AgoraRTC worked fine.
However, there is one problem with Audio.
After turning Audio off in the default settings when joining, Audio is not turned on when I use “Mute Unmute AgoraRTC”.
This gif is when I mute/unmute after turning Audio on with default settings (already in Join). It works fine.

Next, this gif is when I tried to unmute Audio after turning it off with the default settings.
(also already joined).
Workflow looks like it is working, but it is not actually unmuted. The camera works fine.

Also, the Audio icon conditons are as follows

Is there any solution to this? Or is this a reported bug?
Sorry to keep repeating myself, but thank you in advance.

Hello, @ysys0201
Thanks for your request.

if we understand you correctly, you disabled the Audio in the workflow ( Screenshot by Lightshot ), and after it, trying to participate in the Conference with enabled audio.
If yes, please note that it is not possible. In case of disabling Audio from the Workflow, you can’t unmute users.

We tested the functionality of disabling the Audio from the workflow and all the participants of the conference were muted initially after joining it.

In case your idea differs from the one we described above, please describe the problem in more detail.

Looking to hearing from you soon.
Best regards,
Zeroqode Support Team

Hey @ZeroqodeSupport,

I’m using AgoraRTC Component for a Streaming website. When a Streamer starts a stream there are no issues whatsoever. This is a workflow:

However, when a viewer starts the viewing there is no video. This is a workflow:

I’m using Current User’s Unique ID as a room name to simplify things for now

I can see from the debugger that I’m connected to the room, but the there is no video at all. Can you please suggest what could be the issue?

Hello, @tarasmuzon
Thanks for reaching out.

In order to provide you with more details regarding your issue, please share with us the settings for the:

  1. Plugin element (on the Host page) -

  2. Plugin element (on the Audience page) -

Please note that Viewers (Audience) is able to see only the Host’s video, so the Host won’t see any viewer.

Can you please specify if your Viewers are not able to see the Host’s video? This detail will help us to identify your problem more precisely.

Looking to hearing from you soon.
Best regards,
Zeroqode Support team

Hey there, thanks for the message.

This is the Host element:

And this is the Audience element:

Yes, the issue is that the audience cannot see the video of the host.

Hello, @tarasmuzon

Due to the fact that we have some additional questions regarding your settings, can you please add our Support Team email to the list of collaborators to your application and provide us information regarding the page, where we can find the plugin? This will allow us to check your settings and run some tests to fix the mentioned problem.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email [email protected]

Note: avoid the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.
Best regards,
Zeroqode Support team

Thank you. Just added you as a collaborator.

The pages are “stream” and “stage”

1 Like

Hello, @tarasmuzon

Please note that we replied to your request on our Zeroqode Forum in this thread:

Kindly ask you to check our reply and let us know in case any additional information is needed :pray:

Looking to hearing from you soon.
Best regards,
Zeroqode Support Team

Ha, that’s actually a different person :slight_smile:

In any case, is it a requirement that I have to input the name of the room? Can I use an arbitrary generated number/id instead if I can’t use user’s unique id?

Seems a bit limiting if hosts need to manually share the name of the room with the audience.

Hello, @tarasmuzon
We are sorry for this misunderstanding with the app :pray: :slightly_smiling_face:

Yes, the room name should be created manually (by the host), so the plugin will create a Token.
Unfortunately, generating the room name by the User’s ID will cause users to simply not be able to connect because the Current User’s ID condition is used.

Recommendation: Do not use parameters from the URL as the name of the channel (room) or part of it.
Please carefully check the documentation for the Agora RTC component and especially Streaming:

Try to change a bit your settings, accordingly to our Demo Page and let us know about your result:

Best regards,
Zeroqode Support Team

1 Like