Forum Academy Marketplace Showcase Pricing Features

API connection + Json POST without quotation marks

Hi,
I’m trying to add an external API - but it seems that the body of my POST is wrong.
I tested it with other tools and there its working fine.

I think the issue is in field the field users. There the number (150 in my example) dont have to be in " ". Please ignore the checked private - my failure during the creation of the screenshot.

image

I am by no means an expert on API or Json formatting, but from my experience struggling with the same issues, I learned that any fields that are expected as an integer should not have quotation marks. I also learned that for me it was easy to overlook the fact that a value I thought was supposed to be sent as a text string was actually supposed to be an integer as the integer was represented by an actual text string value internally by the API.

An example of that was I kept trying to send the text value of “Created” but the API required that to be sent as 2 since 2 represented created in their system.

Try adding a header Content-Type with the value application/json

both are not working :frowning:

When I add the full json body (without dynamic values ) its working fine :frowning:

Sometimes bubble glitches and you just have to delete the Api Call and create a new one.

already done :frowning:

seems that I solved it. Dont know how.

But i still get the following message.
What I can see is that the record was created.

solved it.

data type = empty.

I usually get that message only on a DELETE API call…did you have this POST go through on the API providers side and double check that when you run the API call through a workflow using dynamic data it also works and creates the data in the API providers database?

I’ve had times when my API call was seemingly fine, in terms of creating the values in the API provider based on the values I had in the API Call itself at the time of initialization, but when I went to use the API call in a workflow with different data values for the parameters it failed.