Forum Academy Marketplace Showcase Pricing Features

API 'Missing Parameters'

Hi,

I’m using an API from Mashape using the Bubble API plug-in.

I’ve gotten several to work without issue. Here is one however that, while it works from the Mashape interface, does not work from Bubble.

The documentation is as follows:

curl -X POST --include ‘https://rxnlp-core.p.mashape.com/generateNGramCounts
-H 'X-Mashape-Key: ’
-H ‘Content-Type: application/x-www-form-urlencoded’
-H ‘Accept: application/json’
-d ‘case-sensitive=false’
-d ‘n-gram=2’
-d ‘text=I love rainy days. How I wish it was raining ! How I wish it was snowing !’

I put the H’s in the headers, the d’s in the paramters… But I get the following error from Bubble:

Missing required parameters [text] & [n-gram] - Missing required parameters [text] & [n-gram]

Is this a bug or am I doing something wrong?

Thank you,
P

can you make a sreenshot of what you wrote in the API connector (without your secret api key) ?

Hi,

Sorry for the delay. I’ve attached a screenshot of the API setup.

Note that I tried the Parameters without the ‘=’ sign as well. I also tried putting the two parameters under the ‘headers’ section as well (both with and without ‘=’ sign) just for good measure.

Thank you,
Paolo

Hmm. Still no luck with this, but not sure if I’ve done something wrong or if the problem is with the API provider.

Still too new to APIs to know.

P

Did you get the call to work in Postman or Curl? That’s the first step to debug APIs, if you can get things to work there, you can then make sure each parameter is correctly set up in Bubble.

Ok, I will give that a shot and get back to you. Thank you!

P