Forum Academy Marketplace Showcase Pricing Features

API workflow not found

I used to be able to connect to this API workflow. I can connect to the other API workflows.
This one is returning a not found error.

{ "statusCode": 404, "body": "{\n \"status\": \"NOT_FOUND\",\n \"message\": \"Workflow not found api_auth_test\"\n}" }

If you want help on API, you really should get the habit of copy pasting the request you’re running. Screenshots are painful to use.

The request was irrelevant. It was just
{ "whatever":"whatever" }
All I did was set the API workflow URL and put “content-type application/json” into the headers.

The point is that it doesn’t even evaluate the request because it’s responding with the not found error.

When I sent that same “whatever” request to this API workflow URL
https://howstr.bubbleapps.io/version-test/api/1.0/wf/link_node_action_test it says there’s a missing parameter, which there should be, because the only parameter in the request is “whatever.”
{ "statusCode": 400, "body": "{\n \"status\": \"MISSING_DATA\",\n \"message\": \"Missing parameter for workflow link_node_action_test: parameter node\"\n}" }

I don’t see what it’s relevant (and it’ll certainly help you having help faster).

Anyway

curl -X POST https://howstr.bubbleapps.io/version-test/api/1.0/wf/link_node_action_test

works here…

{"statusCode":400,"body":"{\n \"status\": \"MISSING_DATA\",\n \"message\": \"Missing parameter for workflow link_node_action_test: parameter node\"\n}"}

So it’s found.

This one isn’t https://howstr.bubbleapps.io/version-test/api/1.0/wf/api_auth_test
{ "statusCode": 404, "body": "{\n \"status\": \"NOT_FOUND\",\n \"message\": \"Workflow not found api_auth_test\"\n}" }

Oh, here’s the API workflow editor, in case that helps.

1 Like

I already fixed it, this happens sometime when the index that stores workflows names is out of sync for a little bit. I’m pushing a fix so that we avoid this situation.

2 Likes

Okay, thanks. I imagine the backend is much more complex than what we see in the editor.

This topic was automatically closed after 14 days. New replies are no longer allowed.