App Deploy - Cloudflare issue

Trying to deploy the app I built on Bubble but I’m new to all this. Can’t seem to remove the my website’s subdomain from Cloudflare. I had been trying to use Cloudflare to manage both my Wix landing page (website) and application subdomain (app built on Bubble) through Cloudflare, but to no success.

I have now reverted the nameservers back to Wix’s and removed my domain from Cloudflare. The website is back online. However, when I try to access my subdomain (app.“mywebsite”.com) I still get an error message from Cloudflare.

All DNS records that suggests for my subdomain (app) have been added through Wix’s DNS management dashboard, and when I log into Cloudflare it clearly states I have no domains attached to my account, since I removed mine. Any tips on how to make the app resolve correctly to DNS records added through Wix?

Managing your root and sub domains on separate platforms is not possible. So I’m guessing Wix somehow copied existing DNS records from Cloudflare when you switch. I suggest Cloudflare on every aspect for your domain management. So start from the beginning, add your domain to Cloudflare and change your nameservers on Wix, then add your Bubble app DNS records to Cloudflare as needed. This is important: Don’t activate Clouflare Proxy on A records for the initial verification, otherwise Bubble cannot verify your records.

I have tried to manage it all through Cloudflare, which did not work (even followed instructions on not activating Proxy), which is why I am now trying to manage it all through Wix. A Type records are all there (domain + subdomain), but only domain is online. App still returns error message from Cloudflare.

This topic was automatically closed after 70 days. New replies are no longer allowed.