Forum Academy Marketplace Showcase Pricing Features

Auth0 API works on postman but doesn't work on Bubble

Hello all,

I am trying to use Auth0 to set up LinkedIn login as the Bubble plugin doesn’t fetch email and I really need to fetch email in LinkedIn login.

I am able to make the entire system work except the last API where Auth0 passes user info (name email etc) to bubble. This Auth0 API works perfectly well on Postman but throws an error when I replicate the same call on the Bubble API plugin. Here are the details.

As seen in the above screenshot, API given the expected result when run on Postman.

Below are the screenshots of the API configured on the Bubble API Connector plugin. and it throws an error.


Can you please help me with this?

Did you set something in the Authorization part in Bubble?

Yes. In the header, I am sending the Authorization in the format needed by the API. It’s the same I set in Postman.

No I mean in the Authorization part of Bubble API Connector. Where you can select the type of authorization and set header for all call.
Share this screenshot too

Got it. I chose the authentication as none/self-handled

Try to add all the same headers you have in Postman. Maybe the server expect something more in header that is missing actually.
Also, be sure there’s no typo in your authorization header (like a space at start or end)

Checked the spacing issues or typos already. I followed your suggestion and copied all Postman header items to Bubble. The same error was thrown again

Create a requestbin and send your request to it from Bubble and Postman. Compare both request to find different.
https://requestbin.com/

@Jici Many thanks. Your earlier suggestion of adding all headers from Postman worked out.

Thanks, again!

1 Like