Forum Academy Marketplace Showcase Pricing Features

☁️ AWS File Uploader No File Size Limit- New Plugin from Zeroqode

Hello, @farmsay101

You can share the link to your app on the Bubble Forum ( direct messages) or write on [email protected] email.

We will be looking to receive a message from you :pray:
Best regards,
Zeroqode Support team

Link sent via mail.

Thanks for help :slight_smile:

1 Like

@ZeroqodeSupport Uh-Oh…

The Uploader stopped working for me today.

I tried reverting to a previous version, deleting the elements and rebuilding it (which was a huge pain) yet still, it won’t upload to AWS.

It also visibly looks different.

I had arranged it to look like this:
image

and now my users are seeing this:
image

Here are the experienced issues:

  1. Files do not appear in AWS
  2. FileUploader’s progress % does NOT increase
  3. Name of file DOES appear as if it’s attempting to upload
  4. Element is visibly different as shown above
  5. All uploaders did not fail simultaneously, but over the past 10 minutes all are now experiencing the same issues.
    • I had multiple uploaders on my site for different needs and some were working while others were not. I could successfully upload to AWS on one last one until 5 minutes ago. (very strange)

I’m concerned it might have something to do with Bubble, because I had not made any alterations to these buttons, workflows, or elements that touch them.

This is critical to my users, any thoughts?!

Hello, @Tyler1
We are sorry for this inconvenience on your side :pray:

First of all, can you please let us know if you started using the New responsive Engine before appeared issues? This is can be a root cause of this behavior.

Let us know if earlier, your files were successfully uploaded to the S3 bucket?

This is the possible reason for this plugin behavior, however, in order to check all these things, please add our Support Team to the list of the collaborators to your application once again :pray:

Also, please let us know which Uploaders we need to check within your application.

Best regards,
Zeroqode Support Team

As always, thanks for the quick response.

  1. I have always used the new responsive engine. I started after it’s release and built completely with the responsive engine.

  2. Yes, they were uploaded to the S3 bucket successfully

UPDATE:
@ZeroqodeSupport

I worked my way backwards undoing each change I made and I did finally find the issue. It’s actually @Pathfix’s OAuth Connector plugin.

When I uninstall their plugin my uploader works correctly and the button looks right:
image

When I install their plugin, uploads won’t go to AWS and it breaks my button:
image

It’s strange to me that it doesn’t seem to break every button all at once, and sometimes it happens to work fine. (1/~100 page refreshes)

With an issue like this, I don’t know if there is an easy fix or if @ZeroqodeSupport , @Pathfix , or Bubble might be able to individually work this out or if it has to be a joint effort.

Sorry I’ve brought up so many issues. I’m a big pain. :pensive:

Hello, @Tyler1
Happy that your investigation was successful.

Unfortunately, the plugin editor is not yet compatible with the New Responsive Engine. Bubble has confirmed that a new plugin editor engine is under development and has top priority. We will migrate all of our plugins to the New Responsive Engine as soon as we have a chance to have them work properly on it. Here is the announcement from Bubble: Plugin Editor & New Responsive Engine [beta]

Thus, some difficulties could be faced during your work on the application. We always strive to help our users, however, the performance of plugins is depending on the Editor possibilities too.

Moreover, sometimes plugins interfere with each other’s proper work, as in this case.

We need to check if the mentioned plugin contains any library that could affect File Uploader Performance :pray:
It can take some time, but we will revert immediately after consultation with our developer Team.

Best regards,
Zeroqode Support Team

1 Like

You’re team is awesome as always.

Thank you so much for the quick responses.

1 Like

Hello zeroqode,

Your plugin is amazing and skiped me many hadaces in handling the horrible AWS S3 developing scene.

But I want to ask is how do i set up the storage file types depding on what content the user upload?

Lets say that when a user upload normal files like PDFs and Pics i want to put the normal uploaded files into a User_files folder with Inteligent tiering and User Identity pictures into a User_ID_Pics with Glacier Instant Retrieval, how can I set the file uploaded to S3 as different storage type files?

Thank You!

Hello, @info.etuuta
Thanks for reaching out.

There is only one way to save downloaded files in different folders in your Amazon S3 bucket ( using this plugin). Please find our instructions below:

Now, you are able to select Uploader depending on the format and files will be downloaded in the correct folder in the AWS Bucket:

Please try all these steps and let us know if this works properly for your case.
Best regards,
Zeroqode Support Team

1 Like

Ahh it worked for creating different folders, but Im unable to change the upload storage class and I need to manually change it on the folder actions, could I upload the file as different storage class like as a intelligent tiering storage class instead of standard?

@ZeroqodeSupport we’re having issues displaying HEIC files that are uploaded using this plugin. They do not show up in the upload preview and Bubble is also unable to render them via an image element on a page.

Do you have a solution or workaround we should try to resolve this issue? Considering the number of people who use iPhones, we’re concerned we can’t get all our users to change their camera settings from HEIC, in order to use our app.

We’d appreciate whatever help you can offer.

Thanks!

Hi
I have problem uploading file using the Uploader Element always return Server responded with 0 code, while the Upload NO GUI element works like charm without any issue. S3 element has been tested and working as well. Only the uploader with GUI doesnt work.
Attach is my sample setup with NO GUI element on top and its result.
Please help. Thanks.


Problem solved.
Solution: for those who encounter the same issue. Avoid using dot " . " in bucket name.

Hello, @benedict
Thanks for reaching out.

Please note that we have tested the plugin from the different versions of the iPhone ( above iPhone 11) and there is no issue with performing the HEIC or HEIF files. Please find our screenshots below:

-

-

Can you please share with us the screenshot with your current settings for the File Uploader element? It will help us to investigate the issue from our side.

Best regards,
Zeroqode Support Team

Hello, @masterpoultrygrouppt
We are happy that you were able to find the root cause of the issue.

In case we can help you with any additional information - please be free to contact us.

Best regards,
Zeroqode Support team

Hello, @info.etuuta
Thanks fo the details.

Currently, there is no possibility to change the Storage class, during the file uploading. The only way is to change them manually.

However, we will take into consideration the ability to add this one for future plugin updates. We need to see how feasible it will be :pray:

Best regards,
Zeroqode Support Team

@ZeroqodeSupport thanks for your response. Please find attached a few images:

We tried uploading a file directly to the uploader on the Zeroqode plugin page, and this is what we got:

These are screenshots of how we setup the plugin settings within OUR app:



Thanks!

Hello, @benedict

Indeed, there are some issues with using the HEIC\HEIX files when you perform uploading this file from the Desktop.
However, this issue is reproduced only with computers\laptops, since from mobile devices all are uploaded correctly.

Please allow us to check this plugin behavior and revert with an update at the nearest time.

Best regards,
Zeroqode Support Team

Hi Zeroqode,

Thanks for a great plugin. Is there any way to create subfolders or are we restricted to folder/file?

Folder creation can be done on AWS end but ideally it would be good to specify the subfolder on upload using the plugin.

Thanks

Hello, @KevinS
Thanks for reaching out :pray:

Unfortunately, there is no possibility to create subfolders during the file uploading.
Please note that you can use the dynamic folder name, so each of your users will be able to upload the files to their own bucket and you, as a bucket owner, will be able to sort these folders by the user.

We will discuss the possibility to add this feature for the future plugin update. We need to see how feasible it will be :pray:

Best regards,
Zeroqode Support team

Hello,

Thank you for this plugin which is very useful.

However, I have a problem when using it in a repeating group.
I have different records with a state that is displayed while waiting for the upload of a file

So we have a repeating group of records filtered according to the state of progress.
Once the upload is finished for a record, a workflow updates the record with the data (url, size, etc…) and changes the status to the next state.
So this record is filtered.

The problem is that the uploader seems to be “fixed” to the initial item number of the repeating group, and not to the data record.
So we find ourselves with inconsistencies, depending on the progress of the records

Example :
I have 4 records
A, B, C, D

I launch an upload on A - item 1
I launch an upload on C - item 3
The upload A ends, so it is now filtered
The display is then
B
C (whose recording is not finished)
D

The problem is that the file uploader remains stuck on item 3 and therefore will apply on D !

I specify that at the end of the workflow I do a reset of the file uploader

Any idea on how to fix this ?

Thanks,
Mickael