Bubble 103 - 4/20 Designing the Navbar- Hiding Login button


Just started working with bubble.

I have followed the video step by step , restarting multiple times but I am stuck.

Either the login and sign up buttons are never visible - (I have the condition Current user isn’t logged in → This element is visible (ticked))
or they are always visible even when logged in.

I have linked photos from google drive


Can anyone help me?


Hi Tom,

Welcome to the community!

Great work on the conditions they are very powerful in sculpting your app

However, you likely have the ‘This element is visible on page load’ checkbox ticked as well, which means regardless of your condition the element will always be visible.

You can find this by right clicking on the Login or Signup button, then clicking Edit. Scroll down slightly on the grey popout and you’ll see the checkbox just under the ‘Tooltip Text on hove’ input.

For the use case of the Login/Signup buttons only being visible when the user is logged out, you want the following setup:

  • Set the buttons to visible on page load using the instructions above. You want them to be visible when the page loads for a user so just make sure the checkbox is checked.

  • Then, set the Condition in the Condition tab for the buttons to be the following: ‘When the Current User is logged in’ - ‘this element isn’t visible’. That will basically check to see if the user is already logged in, and if they are it will instantly hide the buttons. This process is nearly instant for bubble to check and then hide them.

Hope that helps!


Hi Reece,

I have the ‘This element is visible on page load’ unticked and the condition set Current user isn’t logged in → This element is visible (ticked)

I am unable to find the “this element isn’t visible” only “this element is visible” .

I think i might be missing something very simple.

All the best,

Are you sure the current user is logged out? A quick way to be sure is to make a button that logs the current user out and see if your group appears.

Hi Kyle,

Thank you I’ll try that next.


This topic was automatically closed after 70 days. New replies are no longer allowed.