Bug or something obvious? Filter RG with dropdown

Hi all,
I’m hoping for a hand in troubleshooting an issue I haven’t come across before, and I’m not sure if I’m seeing a bug or there’s a flaw in my setup.
I have a job board. On the job listing search page (called ‘search’ in the editor), i have a repeating group that shows all active job postings. I would like users to be able to whittle down their search by choosing a company (this works fine, using a searchbox), full time / part time etc (this works, using tickboxes to modify a custom state-list), salary range (this works, using a slider), whether the employer permits remote work (this works, using a toggle to switch a custom state), and the country the role is based in (this doesnt work?!, trying to use a dropdown menu). I am currently using a dropdown to allow the user to select a country - with the sources of the options in the dropdown defined by “do a search for → job postings (constraint: active = yes) → each item’s location: extract country: unique elements:sorted” so the list is in alphabetical order. The dropdown list is functioning correctly. I’ve tried a few ways to get this dropdown selection to update the RG:

  1. workflow where 'when dropdown value is changed, set a state on the page called country with the value = ‘this dropdown’s value’, with the second step being ‘display data in RG’ based on the same original search filters, and location = page’s country. ignore empty constraints.
    *note - tried making the state a text value, and tried making the state a geographic address. also tried ‘location contains page’s country’.
  2. A different workflow. Skip the custom state, and just display data in RG, as in 1) above but location = dropdown’s value. ignore empty constraints. tried location contains dropdown’s value as well.
  3. Started a new page, created a table for job postings, tried both search constraint methods above and ran into the same issue.
  4. Check how the RG data is being displayed when the user clicks other search constraint options (i.e the ‘do a search for’ and constraints in the repeating group), and it is the same for each. i pasted the same search expression everywhere. So I haven’t entered the incorrect search & constraints in this one workflow compared to the others.
  5. tried creating a searchbox to allow users to search for countries, but then I can’t get the job posting’s country and only unique elements, like I can set it up with the dropdown.
  6. tried above methods but instead of location = dropdown’s value, using location = dropdown’s value:extract country.

The result always ends up being the same - i get a spinning loading icon but the RG doesnt change, and when i use the inspector to look at the RG, i see an error message saying “An error occurred trying to evaluate this property. Sorry, we ran into a temporary bug and can’t complete your request. We’ll fix it as soon as we can. Please try in a little bit”. but this error has been present for a day or two. I’m thinking it may be due to something with using a dropdown in general then trying to change the repeating group (but this wouldn’t explain why i’m getting an error when using the custom state approach), the fact that i’m extracting a country and maybe its a text vs geographic location / address sorta thing that’s causing the error (even though I’ve tried the different types of custom states), or I’m missing something obvious in this whole set up.

Screenshots below for clarity, and the page is labelled as ‘search’. Anyone run into this one before?

Thanks!
ben

Hello @bennymac1

Try using a 2nd rg that uses the texts from the rg that does all of this parsing as the data source of the dropdown. The dropdown would have the texts coming from the 2nd rg

hey Carlos, thanks for taking the time to respond. i’ve tried setting up a second RG, set the content type as text, I’m able to display all the countries in this second RG, i display the values from the 2nd RG in the dropdown (all countries are displaying correctly), but then am still running into the same issue. If i set the ‘types of choices’ in the dropdown as text, i get no search results in the first RG. if i set the ‘types of choices’ in the dropdown as geo address, i get the spinning loading icon and the bug error message in the debugger window… (?).
i’ve also tried setting the type of content in the 2nd RG as job listing, geo address and text, then trying all the possible combinations with the dropdown (geo address, text), and still nothing.
my ‘location’ field in the database is a geo address, so i would have assumed it would be best to keep the dropdown values as geo addresses as well, but i’m stumped on this one. i also tried creating a new field called ‘country’, both as a text & geo address field, to see if getting around the ‘extract country’ would do anything - no luck.
i’ve filed a bug report so hopefully someone from bubble can weigh in.

This topic was automatically closed after 70 days. New replies are no longer allowed.