Builder Crashes a Lot

In case anyone else is curious :wink:

1 Like

I’ll add my own anecdotal data point: Since I started Bubbling in 2015, I’ve never seen that “killed tab” show up in the Bubble editor. I don’t build one page apps, though, so maybe that’s a factor?

I think it’s a huge factor. This page I was working with was massive.

Ever since I broke it down, I have been working in Bubble all day and have only had a few crashes. I think it just comes down to the builder doesn’t know what to do or have any type of recovery mechanism in place for when too many elements are on a page.

1 Like

Maybe, though it will kill the editor in all my apps at the same time (single page or not) and even pages that have a simple reusable open.

I’ll add in that I too have had Bubble crash on me like that every so often. It started happening fairly recently for me, went a few years without ever crashing. It has nothing to do with internet connection. Seems most likely more RAM would fix it. I’m on a Macbook Air. Restarting the browser does the trick, seems to clear some sort of memory cache. I always just make sure to start Bubble fresh each time I’m going to work on something.

Good point. I did as well. It’s really been this year that it’s starting doing it for me :man_shrugging:

One thing that really slows down the editor is the errors notification icon.

If you disable it (adding the query string issues_off=true in the URL), the editor runs much faster.

I use CCleaner every day to delete unneeded files running in the background that hog a lot of memory.

I am also on firefox as it crashes less frequently but i need to use ccleaner daily.

Hey :wave:

Just a small tip. Recently I don’t know why, Bubble builder became too slow and really buggy. I mean after 5-10 minutes spent to buil stuff, it was becoming impossible to continue : ten seconds to take a click or a key on the keyboard into consideration. I never encounter this kind of issue since I used Bubble around 1 year and a half.

I was trying to follow your advice. Change from Chrome to Firefox, update my browser, kill GPU from Chrome, clean all cache, uninstall plugins etc. but still the same problem.

Because @JohnMark mentionned the GPU, I tried the following trick and now it’s incredibly fast!
I just tried with Chrome, not with other browser. Also I’m on Windows 10 so I don’t know if you can do that on other OS:

Go to your computer GPU control panel and choose the right GPU for Chrome. I have an NVIDIA GPU and for Chrome it was on autoselect mode so I think it used most of the time the integrated GPU, not the NVIDIA. So I selected the NVIDIA and saved. That’s it!

Here is a screenshot (in french sorry):

Hope it can help : )


This just saved my life! So much faster!

I’m building an ambitious native app (so many different “pages” all on one page as different groups) and it got to the point that it took 5-15 seconds for every action I took in the builder to finish and save. Almost unusable.

Here’s a screenshot in English for anyone else struggling with builder speed, super slow builder, or builder slowdowns (shameless keyword stuffing).