Bulk update of users

Is there a lag time when doing a large bulk update of 50k+ records and it showing in the database?

I imported 65k users and then did a bulk update using a backend workflow to make updates to the users.

In the system logs there’s no errors and the logs show the fields as updating but none of the records show as being updated.

Have you refreshed your editor? If not do so and it should be fixed

Most definitely tried that.

1 Like

On backend workflow try to run it on 1 specific record. Check if it changes. If not go to the backend workflow & check “ignore privacy rules” then run it on another record and see if it changes.

It may be a privacy rule thing (idk if they apply to bulk data tab flows actually but worth a try)

Yup! Thought of that too. Tried running one record in dev and live modes.

1 Like

Use make changes to a thing - user (your U param)

Not current user. Running bulk flow there is no current user.

1 Like

Just a bit of extra info: Contrary to what many people think you can use “current user” with backend flows, they just need to be authenticated by passing a auth header key (retrieved from an backend login flow). This only applies to externally called or bubble called backend flows with the user authenticated though.

In this bulk flow thing you’re doing “current user “ isn’t the possible. Thanks for providing screenshots :raised_hands:

1 Like

Awesome, thanks for the info!