Can I disable autocomplete on certain input fields?

I have a few search fields in Bubble where they autocomplete FROM bubble as you’re typing. The problem is that chrome keeps popping up its own autocomplete from previous searches over top which is annoying. Can I disable that at the field level?

3 Likes

create your own custom searchbox from input, repeating group, group focus.
autocomplete wont happen at all.
Or try implement some code from here:
https://stackoverflow.com/search?q=disable+autocomplete+ ,

any solution for this ?

I looked around but nothing seems to work for me…

Thanks,
Carlo

I was able to turn this off using the toolbox plugin and on page load running some JavaScript.

Here is the code:

const inputs = document.querySelectorAll('input');

inputs.forEach(input => {
input.setAttribute("type","text")
input.setAttribute('autocomplete', 'off')
input.setAttribute('autocorrect', 'off')
input.setAttribute('autocapitalize', 'on')
input.setAttribute('spellcheck', false)

});  

Hope that helps! :blush:

@j805 www.NoCodeMinute.com

For All Your No-Code Education Needs:

  • One-on-One Tutoring
  • eLearning Hub
  • Video Tutorials
8 Likes

Hi Jason!

Thanks for your reply!
I tried it and unfortunately it seems to not to solve the problem :frowning:
I attach here a screenshot of what I see:

It’s very annoying because the suggestion is hiding the first result…

Best,
Carlo

I just realized that it did it on all of the other fields except the address. So here is how I solved it.

I previously had the placeholder called ‘Address’. Then I deleted it, but that didn’t clear it out for some reason. I changed the placeholder to ‘other’ and that fixed it. So now it doesn’t show up for the address input as well.

Note: I make the placeholder white so it doesn’t show up either.

Weird fix, but it works. Hope that helps! :blush:

2 Likes

Wow, it worked!
Thanks :heart_eyes:

1 Like

Glad it helped. :blush::raised_hands:

Hi Guys, I have Carlo same problem but couldn’t understand this fix by changing the name of the Placeholder.
The box still pops up for me and is extremely annoying.

@J805 I’m having this issue on MacOS when I’m typing in a name. It comes up with suggestions which completely covers all Bubble search options. I have a placeholder. Any suggestions?

Hey @eric10 :wave:

The struggle is real! I have been there!

Can you share a screenshot of what the issue looks like so I can better diagnose the issue?

Hope we can figure it out for you. :blush:

Thank you for your quick reply. Here is what it’s looking like.

@eric10 Hmm :thinking: What does your placeholder say?

“Enter Member’s Name” is what the placeholder says.

For clarification, do I only need a placeholder, or do I still need to have the Javascript? I did not add the Javascript, since I thought the placeholder was another fix. I’m also using a search input not a text input since when I’ve used text inputs with a Focus group it pops up all over the place on a mobile device.

Hmm :thinking: I think I’m also using the JavaScript on the page. I would try it and see if it helps. :blush:

No luck. Added the JavaScript and still getting the dropdown overlay from the OS.

1 Like

Hmm :thinking: That’s a tough one.

Can you share a screenshot of your JavaScript that you added in your workflow? That might help us spot something.

OK, I figured out a fix. I added another field to search email. It was a copy of the first one, but instead of searching full name it was searching email field. As soon as I clicked into the search a bunch of emails popped up. It got me thinking how does it know I’m looking for email? The data field was a text field, so how did it know I was looking for emails before I even started to type.

Turns out it’s looking at the placeholder text and trying to be smart. As soon as I removed the placeholder text “Name” from the first field and “Email” from the second it stopped. It seems to look for placeholder text which describes the field and then does a search based on that.

1 Like

I think I solved a similar problem a while ago by disabling cookies for users page load. General - Bubble Docs

Although cookies are also automatically disabled for new users-- so this problem may not be as visible as you’d think :slight_smile: