Multiline Input autocomplete

Hi all,

I have a multiline input at the end of a signup form that is autocompleting (as street-line 1). I’d rather it wasn’t autocompleting to anything.

I was wondering if anyone has a solution to disable autocomplete on a multiline input?

I didn’t know the multiline input could auto-complete… was this a multiline that was converted to a search box (geo places)?

Sorry, I meant the browser’s autocomplete feature for forms, not the search feature in Bubble.

Here’s a screenshot

1 Like

I haven’t tried this myself but @DaveA suggested this solution!

1 Like

Hey Faye,

Thanks, I did try that and I couldn’t get it to work. It was the only thing I could find on the subject in the forums.

I just created an html element and copy pasted that into it. I also tried running it on the page level and application level. Maybe I’m doing something wrong?

As an aside, I also opened my dev tools and added the autocomplete=‘off’ html attribute to the element to no effect (of course this wouldn’t save or apply any changes). ¯_(ツ)_/¯

1 Like

Ohh! Hmm, I’m not sure either, but you’re probably doing it right! I think it may have to do with Chrome updates that prevent certain codes from turning it off? This thread has some possible solutions, though I’m not sure which ones we’d be able to try in Bubble?

1 Like

Thanks for the SO megathread link - I hadn’t seen that one.

So yea, adding an attribute as such

<bubble-element Input autocomplete="off">

works as expected. Last night autocomplete was filling out a couple of my inputs incorrectly. I can’t remember what I did exactly, maybe delete the input and repaint it in the composer, but it was fixed after some tweaking. I tried adjusting the html attribute then as well, and it worked as it should (turning off autocomplete).

According to MDN the autocomplete="off" attribute should also work for <textarea> elements as well, but it’s not :frowning:

I may be wrong, but I feel it wouldn’t be a terribly difficult fix as far as bubble is concerned. A checkbox on the property editor which generates the html attribute accordingly. At least for inputs, if not textareas.

Here’s MDNs entry - autocomplete attribute is the same as input and form elements

1 Like


Ok so I’ve replicated the fix. Delete the input in the composer and repaint it.

Worked for both input and multiline input


Awesome! :slight_smile: Thanks so much! Good to know that’s how to get it working!

1 Like

Is there a consensus on how to modify <textarea> and other Bubble elements? For example:


textarea {
   -webkit-user-select: none;

I notice that modfying <body> CSS works quite well, but injecting changes to <textarea> does not.

This topic was automatically closed after 70 days. New replies are no longer allowed.