Cannot Create Privacy Rules (bug or user error?)

I’ve watched the tutorial on how to do this and am stuck on creating the “When” clause. When I click the “Click” (with the red border) text I should see a menu/tooltip to help me build my statement (like elsewhere in the application); however, when I do so, I see a “Search…” box but no menu and when I start typing nothing happens (see image below).


Is this a bug or user error? Thank you!

Hi there, @2706mason… you should get a dropdown that includes the options This Workspace Owner and Current User, so maybe you have hit a bug. If you haven’t tried refreshing your editor (and possibly clearing your cache), you should give that a go, and if you still don’t see any options, you should submit a bug report so Bubble support can take a look at your app.


1 Like

Thank you for the suggestions! I tried clearing my browser cache and cookies to no avail. I cannot create Privacy Rules at the moment :frowning:. Hopefully we can get this fixed soon.

I’m having the same issue now. I cant create privacy rules.

Uh oh… submit bug reports for sure… and let’s tag @bubble for visibility.


Bug report submitted

1 Like

From Bubble:

This is Kylie from the Tier 2 team specializing in ecosystem integrations. Happy to help!

I’ve been able to confirm that other users are experiencing this behavior, and our engineering team is currently investigating the issue. Our team will be in touch directly once it is resolved. In the meantime, please let us know if you have any additional questions.

Kind regards,


Same issue here.

Sounds like they’re on it! It’s pretty much stopped my development for now…it’s not letting me save data until I define a privacy rule for the target data type/table. :slightly_frowning_face:

Same here

Same, if it helps at all it let me copy paste expressions still

1 Like

Confirmed fixed on my end. Whew!

This topic was automatically closed after 14 days. New replies are no longer allowed.