API Workflow not working on Live-Version

I feel like I have a pretty good knack for bubble but currently, I am stumped.

I have an API workflow that runs perfectly fine on the test version, but won’t run at all on live.

I even toggled “ignore privacy rules” even though it works good all the same on the test version.

I’m sorry I can’t really offer any leads besides the fact that this API workflow is a duplicate of the test version.

In the debugger I can see that it is in scheduling to the do workflow, but because there’s no way to step by step a backend workflow, that’s all I can see.

Is there any reason why a backend workflow wouldn’t work on live? I haven’t encountered this before in previous iterations.

Hmmm… :thinking: any chance the pause workflows is on on live?

Maybe there is an error somewhere but it’s not showing up on the issue checker because it’s currently disabled.

Turn it on with:


What do the logs show? Is there any chance the data itself is responsible for this? I imagine the live data isn’t the same as test, right?

Server logs and details of the workflow would help troubleshoot this

Didn’t know a backend issue checker even existed, but nah, I’m not getting anything. The workflows are exactly the same, besides the email step. I only put in the email step because I was trying to see whether it was some type of privacy issue on some of the data options. Anyways even if I try to trigger the test-version of the workflow, it doesn’t fix it.

sorry for somewhat messy screenshots. Uploading stuff on windows is a pain in the ass.

I’m pretty sure the logs are running correctly…?

It’s using WU’s but no data is actually being changed nor is it even following step 1 which is to just send an email.

Update: None of my API workflows are firing on live

@drixxon , per Rico’s first reply, have you looked at the Scheduler tab in live and made sure you don’t see a button that says Resume tasks? If you see that button, it means your scheduler is paused, and you need to click the button to start the scheduler again.

I think you might be onto something

1 Like

Is there a way to not have the scheduler pause the tasks?

I use Api Workflows to create-posts, comments, etc for all users.

By “pause” workflows I thought you were referencing something in the editor.

I had no idea the scheduler even existed.

“I feel like I have a pretty good knack for bubble”

You can only pause/unpause everything, it’s really annoying. Another option is to cancel individual workflows and run them again, but yeah… bubble’s logs section leaves a lot to be desired, it is so feature poor.

Just click resume tasks and that’ll start everything firing again.

No need to think we’re onto something… that is literally the issue. :slight_smile:

When you run a backend workflow, it gets scheduled to run, even if the schedule is the current date/time (as opposed to being scheduled to run in the future). If your scheduler is paused, the backend workflows can’t run… simple as that.


Yeah everything is working now lol

Thank you to @rico.trevisan who had the solution but I misinterpreted it

Thank you to @alex.esposito.1108 for asking about the data structure. I was worried that the workflow wasn’t firing off at all. Being able to see that it did indeed fire off, but just never completed itself was useful.

Thank you @ed19 for the clarification. Honestly the logs section is kinda scary and confusing to me. I had a hard time even figuring out whether the logs I was looking at was for the test server or the live server as everything is a white on grey color tone. Also sometimes when you try to change the log settings, it’ll revert to showing you info about the test server despite having just been looking at live server logs.

Thank you @mikeloc for cleaning everything up. I was in the middle of reverting my app version when you replied. I prolly would’ve started breaking things lol.