Clickable icon not showing clickable cursor on hover?

Hi all, I’ve got a pretty simple problem similar to this thread and this thread.

I have three icons of the same style (different icons, same style) with workflows attached to all three, yet only two change my cursor to the :point_up_2: clickable cursor. The two that work (switch to :point_up_2: on hover) are a set of left/right arrows with workflows on each, displaying the previous/next item in the repeating group, respectively.

The one that doesn’t work is part of another group (not repeating) inside that repeating group. I press a “change location” button which displays a group comprised of a text input box, a “save” button, and the “close” icon which is the one causing the issue. I have a workflow on it which simply hides the group. The element IS still clickable, and works fine, the cursor is the only issue here. Really not a huge issue, might just be confusing for users. Saw it in a few other threads and wanted to give some specifics to my situation, hope it helps.

Clickable (Style: Medium Gray)

Not clickable (Style: Medium Gray)

Try it here, in a demo version of my app. Just click “Change Location” and hover over the x icon.

Is this a bug or am I doing something wrong @emmanuel? Thanks.

1 Like

Hey @greg.nallie :slight_smile: I’ve noticed this before too. I think it only happens with certain Material Icons? (not 100% sure though!) If you do file a bug report, as a temporary workaround the ‘X’ icon which comes from the Ionic Elements plugin looks very similar the material ‘X’ icon.

I have same issue

Thanks Faye. I tried a few other material icons, then the ‘X’ Ionic Icon, and none changed my cursor to :point_up_2: despite having a workflow attached to them. Any other ideas?

No problem :slight_smile: Hmm, I just tried in test app and was able to show the hand icon using the Ionic “X” icon. Maybe it’s browser related? Can you temporarily set the app to public and share a link to the app editor?

Must be browser specific… I’m using Chrome on Windows 10. Probably not a big enough issue to be concerned with, but I’ll submit a bug report anyway… thanks Faye!

@greg.nallie, did you get anywhere with this in the end?

No, the issue still remains (in Chrome, at least). Things to check are elements covering the close button, make sure there’s a workflow attached to it, try different browsers, recreating element… etc. Minor nuisance, not a huge priority.


This topic was automatically closed after 70 days. New replies are no longer allowed.