Icon on Hover not showing as clickable

Is anybody else having this problem?

I have dozens of icons that are no longer showing as clickable, despite previously working fine.

The workflows are still triggered, but as a user it is not possible to see the mouse icon change to show as a clickable element.

I posted a bug report a week ago because I saw another thread with one user asking for help on the issue, which I found because I noticed the problem, but haven’t had a response from bubble on the subject.

Anybody having this problem?

1 Like

Let me guess - those icons or group where they are located has been copied from another part of your app, right?
If so - you have to re-create them.
I have similar problem here Icon action now shows as link

1 Like

I am not 100% sure if all the places where the issue is stems from them being part of a copied element and workflow, but if that is the reasoning, that still isn’t really what the bubble team probably would have wanted to have happen.

Still seems like a bug…plus one icon that I know for sure wasn’t showing on hover the ability to click, miraculously started to show it again without me doing anything to it, so still seems like it can’t be justified solely on the idea it was copied.

I believe the copy with workflows in the editor is intended to work flawlessly, and this is definitely a flaw ( bug ).

Hoping to get others to respond with their experience as so far it seems like you and I have, plus another user who “liked” my bug report.

1 Like

Just noticed I’m having this issue as well and came across your post while searching for a solution.

When you hover over them in Debug/Preview mode, they don’t show up in the element tag (bottom right) when you’re hovering on them while hover conditionals are enabled. If you move your mouse fast enough, they register for a millisecond, just enough for the text to change to whatever element the icon is sitting on.

Still haven’t found a fix.

I was using Feather Icons fwiw.

I am not sure if this is true or not, but I was just having an episode where an icon was not showing as clickable. This made me think of this thread.

At first, I felt like there is a problem that should be reported, but I went deeper and found that if I didn’t have a workflow that started on the click of the icon then the icon wouldn’t show as clickable.

However, once I added a workflow whose trigger is the click of the icon, the icon showed as clickable.

Note, this is on a new app and I have not bothered to verify this theory on my other apps I experienced the issues with. My assumption is this, could have been the reason I had issues in the past and didn’t look deep enough.

Sorry, no this is not true. I just experienced this issue again. It is such a random thing.

A previously working icon with a workflow for click showed as clickable…then randomly it stopped working.

I would show screen shots but I can’t because the cursor moves to take the screen shot.

But this problem is still persisting.

Anybody else experiencing it? If so, what are you doing to eliminate the issue? I am open to any suggestions as long as I don’t need to worry about it any longer.

I was having the same issue.

In my case it only affected material icons placed in a group, but not all the time. For some
unknown reason it worked for one instance of the exact same icon. (1 out of 8)

I simply ended up using Ionic icons instead, that looked near identical and worked fine.
If there’s a very particular material icon that doesn’t exist in a different icon pack, a quick and
dirty work around that worked was to place the icon in a group and run the workflow on the group instead.

so, seems like a bug?


I have come to the conclusion that it is a bug but not able to be reproduced on a regularly basis so the bubble team is not attempting to solve the bug. As you mentioned the work around is to place the icons into a group and run the workflow etc. on the group to ensure the element is shown as clickable to a user.

I personally started to use thenounproject.com for icons that are downloaded as a SVG or PNG file. I choose this as they have customized icons that you can search for to fit any particular project.

1 Like

It is still happening to this date. I used feather icons, I thought the problem was in the workflows but after various and various attempts, I realized that the icon was not clickable on hover. @boston85719 thenounproject.com is a great resource! Thanks.

Yeah, it still happening to this date. Surely it’s a bug, a random one that you cannot replicate. In my case I have a container group with all elements outside the header, and unchecking off the option “Lock this element” for this group solved the problem of its inside groups not being clickable and not triggering the workflow.

1 Like

same issue for me.
I’m using iconify icons inside groups and creating my workflow in the group.
the Iconify icon is not clickable - and hovering over the group, sometimes, does not show a Link cursor.
-but the workflow still runs if clicked. :man_shrugging:

Hi There, have you already found way to solve this issue?

If you are experiencing the issue, please report a bug to Bubble so that maybe they will fix it.

I could fix this issue in my Herofy plugin, make a box around the icon and make it so that always acts as the wrap so you always click the area where the icon is and don’t have to physically put your cursor on your icon to make it activate. Is this what you guys are talking about?

The original post from 4 years ago was referring to the fact that an icon when it is clickable doesn’t change the cursor to a hand to indicate it is clickable.

Hi Sir, I was asking edt3 because I managed to make it work in my project without any 3rd party plugin or what so ever. Just want to share him the procedure how to do it. have a great day.