Forum Academy Marketplace Showcase Pricing Features

Conditional data source problem using Fuzzy Search & Autocorrect

Just see the headers, no events.

Whoo Hoo! Played with the conditionals

You are a champion. I don’t know where you get the patience :sweat_smile:
Couldn’t have done it without your help today.

Having deleted “Specific Resources” what’s the implications?

Anyhow, you’ve been fantastic. I’m going to try to figure out how to remove a person who has a day off. The fields I need to filter on should be obvious from the resources now I can see them.

So, it means that, your calendar only knows about a resource if that resource already has at least 1 event that’s in the calendars current events list

That means if you hire Tom and Joe, they won’t aporrear on the calendar because they don’t have any events associated with them thus far. Think day 1, haven’t been scheduled/taken time off/etc

bUT

If you set the specific resource list to include Tom and Joe, even with neither of them having events in the dB yet you’ll still see them as a resource on the calendar.

Then after you get this setup we can chat about grouping and adding resource images :wink:

That’s exactly what I want to happen. What it means is I don’t have to look to see if they’ve explicitly scheduled themselves for a day off. They simply won’t have any grooming tasks assigned to them on that day and won’t appear on the calendar for that day.

Hi Jared
Two things please.
(1) Actually, I have to handle the day off situation differently because there is a LiveBooking on the day.
So, I tried a conditional to exclude days off (indicated by the “yes” shown below).
Please check what I tried and advise.
(2) I know I had the tooltip working some time ago. I have it enabled in the initialise event but can’t find it in the FullCalendar settings. I want to set the tooltip to the LiveBooking’s “Title”.
Thanks again.

Thanks.

Hi Jared
On the version 1.46.8 my headers and bookings show but if I upgrade to 1.48.1 they are both missing.

Did anything come up in your issue checker? Sometimes when you upgrade you might have to redo some settings.

Hi
Thanks for picking up on my post.
No issues plus no developer tools console errors.
However, when I upgrade I do get the following console errors.
Jared, the Plugin author, is very responsive but he’s probably pushing Zzzzs in Detroit at the moment :wink:
Stay safe.

It’s still there. In the same place as before. I didn’t move it I do t think. I’d recommend you go back, slow down, and read each setting carefully on the initialization workflow. There’s a lot to go through but it’s definitely there.

this had to do with not having anything in the specific resource list. my fault. i have added some protections for that.

update.refresh.and check it out again.

please note, this is a BETA test version that you’re on and more prone to errors that are my fault than the last stable version you were on (1.46.8)

thanks for the input @equibodyapp

always a good start.
next check all the settings and inputs.
then
i always go to the console next.

I checked and cannot see it anywhere (other than setting it to be active in initialisation - see yellow highlight below) . Below are screenshots of the initialisation followed by the Full Calendar settings. I am on version 1.48.3 (latest at time of writing) and cannot see where to say what to show in the tooltip.

Also, how do I change the week dates to dd/mm not mm/dd?

ahh. i see. it’s always the title. there was never an option otherwise.

ddd DD/MM

you’ll likely want to set conditionals to change based on the view
i frequently reference this page to set up these date/time formats

Thanks for the cheat-sheet but I still cannot change USA format mm/dd to NZ format dd/mm.


Your assistance is appreciated. Thanks.

Only the string portion is what you should use.

In your example. Just

l


This will give you what you’re looking for ^^^^^^^

Sorry Jared. I’m still not getting it.

@marksrunge here’s your legend. Use whatever combination of these to create the display you want.

1 Like

Many thanks again for picking up on this.
My suspicion at this stage is that the below setting isn’t related to this week view


For example, I can change the date setting below but nothing I do to the above setting changes the mm/dd to dd/mm