Forum Academy Marketplace Showcase Pricing Features

Connecting bubble.io with google domain

Or setting up dns records?

I tried for hours, dug through youtube and google with every keyword around the topic and I can’t figure this out

I attached the screenshots of my current set up
I have no idea and I’m completely stuck
Very frustrated

site is called 1a-cars.net and currently looks like this:

This if I click “run” on bubble:

edit: I can’t work on the webpage anymore either now ever since I tried to actually publish the site and connect it to my registrar google domains

what i see

1 Like

So it was up for a second?
For me it suddenly completely deleted. I can’t find it anywhere on bubble anymore now

Then I tried to re-start with the template I had bought, but now bubble tries to charge me a second time

I think it thinks it’s a second app or something? This is all of frustrating


Now I have to start over with both the app and the domain connecting and pay a second time for it all?

Weird stuff! Your app definitely should not have deleted without you intentionally deleting it. When deleting your app, Bubble asks you to type the name of the app exactly as it was made to prevent mistakes. If you didn’t do that, and it’s gone, file a bug report.

Regarding your DNS record connection — if done correctly, it can take quite a few hours to propagate.

My recommendation would be to delete all your A records in the Google Domains portal and also delete the domain name from the Domain/Email section of your Bubble app. Then:

  1. enter your domain name exactly as it is into Bubble and press “Change app domain.”
  2. add the four A records to Google (note—when doing the “www” records, do “www.yourdomain.net

After this, let it sit for a little bit—again, to let it propagate. If none of this works, search the forums widely for this (as there is most likely plenty of others that had difficulties with this) and ask there. There are plenty of Bubblers who are happy to help.

1 Like

Sounds great, do you know how I can change the plan to personal to do that? It doesn’t let me without charging me again - probably because this is “a new project”

To my knowledge, there is no way of upgrading to a Personal plan without paying. I think an email into support may be called for here. If not to try and regain access to your original app already on a Personal plan, at least try and get a refund.

1 Like

It’s gone from the dashboard
I sent an email to support

Edit: how long does a response usually take? 24h?

I’m about to release my app using the same system, i’m just waiting for propagation, hopefully i’ve made a backup after i’ve read your message.

I let’s you know if it’s working for me !
Good luck