Forum Academy Marketplace Showcase Pricing Features

How could I connect my Domain into bubble?

I recently bought a domain with .xyz. Is there any way for me to connect it into bubble so I could possibly have people re-direct from my link rather than bubbles?

Hey,

On Bubble, you can only use a Custom Domain and remove the Bubble Banner on a Personal Plan, for more information, please go to your app’s editor and click on Settings.

Under Settings ⮞ Domain / Email ⮞Domain Settings, there is a section for you to add your .xyz domain. And that is all you do on Bubble’s side.

But in order for this to work you need to change some settings in your domain manager where you bought your domain (such as GoDaddy etc.)… In your domain manager you need to change your DNS settings to the following:

Type: A
Host: @
Points to: 54.69.164.32
TTL: Keep this to whatever the default is.

This will then point your domain to bubble. Give it one or two hours to connect and it should then be working.

Hope it helps. Let me know if you get it working.

4 Likes

I can agree. This worked. BUT, as Profamii said i need a personal plan. Which I kinda don’t like as I already pay 10 monthly for my domain.

You can’t pay for a domain monthly, you only pay yearly. Where did you register your domain?

Well actually it depends on what plan i pick. And to be honest im hosting it from my own server. The domain+ssl+Priv email+website on the XYZ costs 10. If i changed it to yearly it would be a little more.

1 Like

The domain lsrp-cad.com is connected to a Bubble application, but the application’s plan does not offer a custom domain.

If you are the owner of this app, please upgrade the app plan with Bubble to restore the connection.

how would i be able to get this to work?
is it making me buy a different plan?

Yes, you must pay for a Bubble plan to use Bubble on a custom domain.

well thats stupid

Considering the many opportunities Bubble offers, 16$ doesn’t seem enough to pay in my opinion.

3 Likes

Hi there, I am having a similar issue, I do have the personal plan, and my domain is shown as verified.

The domain in question had a wordpress on it prior to it and is now showing the database error.
I did move that old wordpress to a subdomain app.mydomain.com and would like to have my bubble.is application using the main domain.

I have edited all the A records but did not remove them and recreated new ones, not sure if that could be the issue.

I tried checking and unchecking the SSL but no luck.

Thanks for any advices.
Franck

I do know that having overlapping records can cause problems. Perhaps try delete all records (that you have created) including previous and new ones then recreate the new ones. Also when transferring from from one domain to another it could take several hours to activate so maybe you just need to wait it out? I am just speculating but hope something I said might help.

Thanks so much, I will wait until tomorrow to give it 48h and if nothing has changed I will try that.

I had the same issue @franck.asseray. Mine FINALLY isn’t showing an error page, and I now can continue to work on my app and use the preview mode (something I couldn’t do while the domain was in-process of deleting). It took a total of 5 days for me.

I have my original site (squarespace- before I knew about bubble as like a signup page till launch), and it is through google Gsuite. So when I saw the google connect button I just assumed I could start the crossover process that way, but then I went back to working on my site and tried preview mode, I got a redirect to my squarespace site’s error page… I deleted the link in my settings immediately, but then it took 5 days to fully disconnect. I can successfully use preview mode again.

Now I’m back to square one of having my bubble (edit mode) site and my squarespace sign up site. Maybe I need to delete the square space first? I haven’t found any information in the forum or the documentation about redirecting yet regarding this. This was the closest thread. If anyone else has and would like to share that link, please advise. Or if anyone understands my rambling and knows what Im trying to do, please let me know. Also Ill repost here upon success- if I figure out what Im doing or a thread that helped.
Cheers
-ALI

1 Like

It did work by waiting it out, erased an re entered some of the name record, the team @ bubble was very helpful with deactivating the dns check for cloudflare, as well as any issue I had, and everything is now working fine.( it was resolved within another 24 hours after the post above) You can check online on the doc of your domain provider( or CDN) on how to point a domain and a subdomain to different servers and it should work.

Yea the folks at bubble were extremely helpful with me as well. I’ll need to disconnect my squarespace connection (I purchased my domain through google) when I’m ready to go live.

1 Like

I have the same issue, using square space I cannot PREVIEW in DEV and PROD is super slow, what didyou do to fix it??? @eve