Creating a login page for a mobile app

Hi, I’m creating a login page for an app however I keep getting the below error.

Ideally I wanted it to be a login page, and when a user submits their data, the data stores, checks if it’s in the database and then if accepted it directs the user to a dashboard screen. If it’s not accepted they get redirected to a sign up screen. Can anyone help me get this to happen?

I’m not sure what’s causing it, but why don’t you duplicate the index page, set the duplicate as the new index and update your go to page action and see if the problem repeats itself?

1 Like

Hi @yousif, thanks so much for getting back to me and I’m sorry for the delay. I’ve just tried this but I still proceeded to get this same error (attached below). Would it help if I shared the way I’ve done the login page, maybe I configured it wrong?

As far I understand, When you check the “Native” option in page setting, bubble expects the app to be built in a single page and hence it doesn’t support navigation action to other pages.

2 Likes

Hi @alan.thomas111997, thanks for getting back to me. Does that mean in order to build an app for the Play Store I need to build it all on one page? I feel like I’m missing something here.

Yes @garethwork421 , you can use url parameters for navigating within the single page. Here is a good article to read more on this > Single Page Apps in Bubble.io without code

1 Like

Hi @alan.thomas111997, thanks for sharing this with me. It’s very interesting. I’ll try doing these steps and see what I can create. How do all the different layers work with doing it all on the same board?

Yes, keep tab views as reusable elements on the same page and make it visible/hidden based on url parameters.

Hi @alan.thomas111997, thanks for the article. Did you manage to do it as described? I read the article, followed the instructions, and even checked things out through the editor to see how everything is set up. However, I can’t deploy the application due to errors.

If “Native” checkbox is unchecked, then you shouldn’t be seeing this error. Could you double check please, if it is unchecked on all pages.