Current geo-location not working?

Hey this was working when the app was on a domain, now ive moved over to my domain its stopped working.

Is this becuase bubble is HTTPS and so browsers allow websites permission to ask and ‘Not Secure’ sites default, at least for Chrome is not ask?

I may be answering my own question here but do I need to get SSL to grab users location?


I think you’re correct here with your assumption of SSL being a requirement. Not 100% sure, mind you. It’s fairly easy to add a SSL certificate -> go to the app domain settings tab and check the box at the very bottom, the cert takes no more than an hour to fully activate. Keep in mind this might not be available depending on your subscription plan with Bubble.

I think it is the case, but i’ll confirm in an hour- now that i’ve checked that box! thanks for the heads up :slight_smile:

Confirmed :slight_smile:
Got the magic location permission box appear now that i’m on HTTPS :slight_smile:

Next problem, it keeps defaulting to Antarctica :confused:

In the Bubble editor strangely its spot on but in both /version-test and live its Antarctica everytime. Even after allowing permission via browser.

Any ideas?

This might be caused by your browser if you have “Do not track” policies enabled. Have you attempted on multiple devices and/or browsers?

Caching issue, cleared out the browser and now works perfectly :slight_smile:

This topic was automatically closed after 70 days. New replies are no longer allowed.