Forum Academy Marketplace Showcase Pricing Features

Origin does not have permission to use Geolocation service

Hello,
I’m building this app that requires the user location to show it on a map. I’ve been working on it for some weeks now and the logic behind it seems to work nicely.

A few days ago I bought a domain at Godaddy and started using in my app. The domain is working. But I can’t get geolocation services anymore.

After a while trying to figure out why my app wasn’t getting the current geographic position I decided to try and delete my custom domain to see if worked. It did, using .bubbleapps.is I got no problem. But when I choose to use my custom domain the browser not even asks me if I allow the site to know my position. I just notice this error using the debugger.

That’s what I get!

I wonder if maybe I need to get an SSL certificate? But my plan doesn’t even support that so I imaged it wasn’t necessary since it has worked already.

Have you experience any problems like that? Is there a solution to this problem? Maybe a setup that I need to do with Godaddy…

Thanks

My guess is you haven’t granted location permissions in your browser. You might try (on the domain you bought) to manually grant location permissions for the URL within your browser or launch an incognito browser and accept the geolocation prompt (if it’s available)

1 Like

Hey Luis :slight_smile: I read in the post linked below that most browsers require the SSL certificate to pull the current geographic position:

1 Like

This seems to be exactly my problem.

What he described is what’s happening to me. There’s not even a request I just get the position blank.

Thanks very much for the help. I’ll do a little more testing but I don’t expect to find another solution. Guess I’ll have to pay a little more for the SSl certificate.

This topic was automatically closed after 70 days. New replies are no longer allowed.