SSL Certificate Setup - Geolocation

I have setup the SSL Certificate with my domain registrar (1&1) as shown below:

I have enabled the checkbox on the Domain/Email tab of my Bubble App as expected. However when I try to load a page that requires geolocation I get the “Origin does not have permission to use Geolocation service” which is, as far as I can tell, due to the fact that my SSL is not being used.

Any hints on what I might be doing wrong? Is there anything I am missing beyond getting the certificate from my domain registrar and selecting the checkbox in my App settings?



SSL is managed automatically by Bubble, so you should check the box in the settings tab.

Hello @emmanuel thanks for your prompt reply. My question is because I have checked the checkbox and two things are happening:

(1) My App is trying to launch a normal http (as opposed to https) site and it is not being displayed at all, instead I get a generic website from my hosting see below:

(2) If I manually navigate to the https:// site I get a blank site with a valid certificate.

Any ideas what is going on? Any way I can get help to figure this issue out?

It looks like your problems are upstream with your domain registrar. It appears that 1&1 is pointing to a 1&1 landing page, not your Bubble application.

So, Bubble may very well be applying the SSL certificate setting correctly, but 1&1 is still pointing to the landing page, not your Bubble app.

It’s possible that you have some conflicting records within your 1&1 setup or it hasn’t propagated. (Note: I don’t claim to fully understand time to live of DNS changes, but this should provide context).

Thanks @dan1 but this has been going on now for a few days (more than 3) so I suspect it is something else.

For some reason my app is not loading in https://. I have checked the SSL checkbox but when I click preview (in my App) it tries to open an http:// location.

Furhtermore, if I open the https:// version it opens a blank page with a valid certificate:

I am more than happy to reach out to my domain registrar if there is something that needs to happen on their end, it is just that I do not even know what I need to ask for. I have checked that the IP address for Type A and Type A WWW are as given by the App. As shown above I have checked that a SSL certificate is available for my domain.

Should I write a help request for Bubble? Could this be some sort of corner case and be a bug?

I am really at my wits end and I really do not know where to go from there. Any other help, hints, pointers would be much appreciated.


Be sure to configure both types in your domain registrar:

1 Like

Hello @JohnMark, Yes both records have the right IP address :

Any other thing that could be getting on the way?

When I tried your domain (https) it gives me the good news. Have you another conflict app? I know you show the detail of Bubble acceptance, maybe time for a small bug report? I feel is something we missed :wink:

Thank you @JohnMark for your help. To be honest I gave up on 1&1.

Not sure what the issue was but (1) I Started my transfer to Google Domains as it seems like it is the recommended hosting for bubble, and (2) Got a “secondary” domain while the domain transfers occurs.

With the “sencodary” domain in Google I got it up and running in less than an hour.


1 Like

Good choice. Happy it worked. It was finally easy! :slight_smile:

This topic was automatically closed after 70 days. New replies are no longer allowed.