Data Display in a Pop-Up Issues

Scratching my head on this one. Have followed a few threads and still not getting the desired result.

Have a repeating group (list of childcare centers) and goal is to click an “add note” button inside one of the cells to launch a pop-up to add custom notes on that specific daycare. Hope is to pass the specific name of the daycare through into the pop-up so that the user doesn’t have to manually do this.

The add note button is in a cell that is nested in the group above and is inheriting the data from the cell above.

A preview here returns a list of daycares that have been filtered/favorited (this may be where the issue is - but given that I am passing info through (instead of redoing the query), I wouldn’t expect this to be the problem). The specific daycare “Our Little Daycare” is what I am trying to do the data display on.


The pop workflow is as follows:


I’ve tried a few different options in here. What I am not seeing (which I have seen in some of the other forum threads) is any sort of “current cell” option.

Next is what the pop-up settings are:

And the result, when previewed, which is returning only the first entry (Thunderbird) in my daycares database.


Any suggestions? Am I missing something here?



Could you share your editor link?

Seems like you’re doing it all right, but places I’d check:

  • conditions on the popup that might be changing the data source
  • verifying that the Add icon is indeed pulling from the right data source (you can check by running your workflow with debugger on “step-by-step” mode

Thanks for the quick reply. Doing some tests and I think the problem is that I am sourcing a “list of” field as opposed to a field with multiple entries. I’ve been able to get this to work fine when I test it on a more simple setup but routinely get a warning when trying to do this on my “list of”. Screen grab attached.

Going to re-visit how I am populating this repeating group first and see if there is another way first.

This topic was automatically closed after 70 days. New replies are no longer allowed.