Data types conflicts


I need to change a field of a type that is a number. The value is supposed to come from an input, however, it seems that is not possible to format an input form to be a number. So when the user types the Tip amount ( a number) it wont allow the workflow to run. Due to the mismatch of field type and the data type coming from the input form.

I have tried to format the input value to be a number, a decimal, a currency, but nothing works. and when I try to format to a number, to make it match with the field, it keeps asking for parameters:

I also tried to hack it by putting the same value into a text, and send this value to the workflow value, but on the workflow I cannot make the value of the field to come from that text element.

If the input element doesn’t work with number? how to allow the user to input a number???
or What to do to allow user to digit the desired amount of tip?

The tip field on the data type is set to be a number, by the way. In order to add up all the values later on.

I hope I made myself clear, if not, please let me know. Thanks in advance for your help

The Input has a field called, “Input Type.” You probably need to change that to be a number. Based on what you’ve shown here, that’s what I would guess the problem is.

1 Like

Hi @andrewgassen

Thanks for your reply. The input type (shown in the element appearance window as “Content format”) doesn’t display an option to be a number. It does show the option to be: "Text(numbers only) however this creates a conflict when I try to Use the expression in other workflow, showing a message. The problems seems to be that it is not actually a number, but still text. So, bottom line, the input doesn’t give the option to be a number

You’re right, it’s not called “number.” I think you’d need to choose either Integer or Decimal for it to work properly. Have you tried that?


Hi @andrewgassen!

yes, I have tried both. The thing is that the input is supposed to be the value of the tip. I don’t have it very clear what’s the reason for this to create a conflict. Either Currency, integer or decimal seems to work. What to do?

There must be a way to make the input to register a number and to create a register on the database. How?

I’m having this same issue at the moment - I have an input, with type “decimal”, and when I try to save, use, or do anything with the value inputted, it just doesn’t do anything. I think this is a bug at this point.

You have the data type set up correctly in the database right? The datatype should match up to the input data type?

This topic was automatically closed after 70 days. New replies are no longer allowed.