Forum Academy Marketplace Showcase Pricing Features

Database not working

Something is wrong with my database or the database. I don’t know what is going on. Its been like this from last night (when I noticed).

I have some fields like [Current User’s Name], [Current User’s Phone]…

On the page its supposed to show the [Current User’s Name] and if that field is empty then it just shows “Name”.
This has been working just fine for weeks now and suddenly now its not working. I haven’t made any changes to anything related to that field. I have my own info in the database (I can see it there. My name is listed under the name field, and my number under the phone # field). But it won’t show on the page. Yes, I am logged in as that user; that is the only user I have listed there right now.

Another example, I have a group that is supposed to show which prompts for the person’s phone #, if that field [Current User’s Phone] is empty. As I stated above, I input my info into the database already so my name and number is in there. But this group keeps displaying on the page prompting me to input my phone # when the info is already there in the database.

A 3rd example, I logged in using facebook. That works fine, but if I log out and then try logging in again without facebook (just by typing my email and password) - it tells me the password doesn’t match. But, that is my email and password. I even tried going to my facebook page, logging out of it and logging back in to make sure I have the right password and I do.

It wasn’t doing any of this before. All other workflows seem to be working fine, its only the ones that pick up info from the database that are not working.

And yes I’ve refreshed the database, I’ve reloaded the page (and app), I’ve done a hard refresh (F5), all of this multiple times. It still shows my info in the database but is not showing up on my page and I’ve made no changes to any of this. I’ve also deleted the entry from the database and tried entering it again, only to see the same problems again.

I have noticed the same thing this morning, had to deploy 4 times to have the changes take effect too. ever a different browser showed old content. let me know if your not planning on submitting a bug report and i will.

1 Like

OK thanks. I figured it can’t be just me. Its happened with every field I input information to, so I know its not something I somehow did in my workflows. I didn’t change anything there!

Like you, I also tried using different browsers, as well as my phone, to no avail.

I haven’t submitted a bug report before so if you know how, please go ahead and do so. If you don’t mind tagging me on it (if that’s possible) so I know when there’s an answer too, or just letting me know what happens that’d be great!

Thanks!

For future reference, you can submit bugs by going to your app, clicking the “Help” drop-down menu and then selecting “Report a Bug”.

3 Likes

We’re running into some weird issues on the Bubble side right now. Submitted one as a bug. We’re stopping development for an hour or two in hopes that it’ll be back to normal in a bit.

1 Like

wondered how long it would be before someone built a plugin that broke bubble… lol

I’m still not seeing a difference. It appears my info still isn’t saving into the database, even though it shows on the data page. This is not an error on my end! I did not change anything here.

Is some kind of fix being worked on?

Emmanuel mentioned to us that we may need to wait up to 24 hours for a search issue we found to be fixed. I suspect this is because it could be related to what’s cached.

That said, we have seen a number of the problems from yesterday resolved. But, not all of them yet. Good enough to continue developing though.

OK well thank you for responding. I will continue working on my site until then. Please keep up posted!

Is anyone else having this problem? It still is not working.

This is really frustrating since it still is not fixed! and no one seems to be saying anything. Everyone else’s logins and data is saving ok, or does no one else’s app use these features? I see a bunch of new topics posted here but nothing regarding this issue and its been like this for over a week.

I have pictures of what is happening.

Page is loaded - prompts to user sign up.

After signing up, page loads and is supposed to show user’s information, A box shows up to display the logged in user’s information. Box only shows up when user is logged in.

Except…

It doesn’t show the user’s info at all. It just shows empty fields, even though the box shows up as if the user is logged in.

Check the data tab, the information is there…

Why is information showing up in the data tab but no longer picking up in my app? This affects the functioning of the app because it has conditionals based on what information is there but the app is no longer recognizing any of the data so it basically won’t function properly.

@sridharan.s Do you have an update or any colleagues of yours have an update on what is going on? It has been days now and there is no transparency on what is happening. If you all are still trying to find a fix, that’s fine but it would be nice if someone would say what is going on.

I really wish the Bubble team would address this as well. I’ve been in touch with them only in so far as I’ve been submitting Bugs, receiving short responses, and sending follow-on thoughts throughout the week. I get the sense that they’re not taking this seriously at all which is very frustrating.

We have huge issues with our database right now. Data will show in the logs that it’s getting stored, but then it won’t appear in the database. In other instances, we’ll run the same workflow hundreds of times and it’ll not store the data 5 of those times. And, then when we’re missing some data, everything else that depends on that data gets thrown out of whack so future actions then load data incorrectly, searches don’t work properly, etc.

We’ve done a bunch of marketing to line up participants for events on our system for Monday and Tuesday and it’s looking like we may have to cancel them because our events will fail to function with the current database issues.

They said they’d look at these issues, but probably not until Monday – that’s what I’m hearing for these database issues that we submitted on Wednesday. Makes me wonder how in the world are we going to run a production application on Bubble? …We can’t have our product non-functional for 5+ days at a time.

3 Likes

We’re looking into it and investigating.

2 Likes

@sridharan.s Thanks for the response. From your previous reply, I was under the impression that you were a part of the Bubble Team! Anyway, I’m glad at least to know that I’m not the only one having the same exact issue because I’ve been wracking my brain going over and over workflows and trying to determine, did I accidentally change something? Is this a glitch from an element I added? And I keep finding nothing wrong with my setup! Its been the same as it was when it was working fine. Anyway, thanks very much for letting me know so I’m not driving myself crazy here!

@emmanuel Thank you for responding! Please, please can you or anyone from the team keep us updated! Even if you’re still investigating. It is helpful to know that you all are actually looking into it, because otherwise it gets more frustrating for us, thinking the problem is being ignored. I hope you all are able to figure it out!

1 Like

I wanted to thank the bubble team for working on this over the weekend and pushing a fix late last night. Each of the problems we were having with our database are fixed and working. We’ve run over 100 tests on our app / database this morning to confirm that those portions are consistently working and they each check out. Thanks again!

3 Likes

I’m having the same problem as well. Just noticed it this morning but could have been going on longer since it’s occurring in a chat function that i hadn’t been working on for the past week. All the messages for the chat function still exist in the data tab, but my app indicates that there are no messages.

@emmanuel, what is the status of the fix that sridharan mentioned? Are there still outstanding issues?

Thanks!

All issues that have been reported have been fixed. however, if the data creation was before yesterday night, some data may be missing. Newly created and modified things should be fine now.

@emmanuel

Hi Emmanuel, I’m still having the same issues.

I have a page that has the login. I try using the facebook login. That works, it enters the Facebook first name as the user’s name. After logging in, I have 3 ‘set state of page actions’ in the workflow, which are based on whether the name field is empty and another field is empty or not. After logging in with Facebook, its supposed to skip the first ‘set state’ action since the name field is not empty. (and it isn’t - it shows the name in the database). But instead it goes the first ‘set state’ with the ‘when Name is empty’ condition. So it ends up prompting the user for their name again, even though it already got that from Facebook.

Also, if I login in with Facebook, and then log out, and then log in again regularly (without facebook). It doesn’t recognize the email and password, even though it is the same as what is used for the facebook login! This wasn’t an issue before.

Along with that there are numerous minor conditional errors that I see on various pages that were not there before (like, for an element; if this field is not empty, show this color) but instead it shows the color as if it were empty. Even though, again, I know the field is not empty because the information shows in the database.

I tried clearing my cache and cookies, I’ve logged out of here and logged back in, refreshed the page, etc…

I don’t know if this is related but weeks ago when things were working fine, I’d always have to log back in to Bubble. It would kick me off every few hours, maybe like every 12 or 24 hours, If I left the window open. Now I notice it doesn’t do that anymore, which is convenient. But I also now have this database problem - so, not sure if that’s related at all. But again, I’ve tried using other browsers, and tried entering information from my phone as well and it still doesn’t work right.

Forgive me, as I am now writing the obvious. Just in case. Did you try to recheck the Privacy rules for the table in the database? It may be a problem with access granting.

2 Likes

OMG @stavvit I love you!!! <3
It wasn’t obvious to me!

I remember looking at the privacy tab awhile ago and I must’ve clicked on one of the fields and cleared everything else or something. I just deleted the role and now it seems like everything is working fine now!

You are awesome! Thank you so much!

I’m still testing and running through everything to be sure but so far it looks good! Sorry @emmanuel I really didn’t realize that I did that and that then affected the entire functioning of the app! I’m still learning stuff on here.

1 Like